aboutsummaryrefslogtreecommitdiffstats
path: root/community/lazygit/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/lazygit/APKBUILD')
-rw-r--r--community/lazygit/APKBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/community/lazygit/APKBUILD b/community/lazygit/APKBUILD
index 41936e1cba1..352b74d7995 100644
--- a/community/lazygit/APKBUILD
+++ b/community/lazygit/APKBUILD
@@ -1,22 +1,25 @@
# Contributor: Thomas Deutsch <thomas@tuxpeople.org>
# Maintainer: Thomas Deutsch <thomas@tuxpeople.org>
pkgname=lazygit
-pkgver=0.28.2
+pkgver=0.41.0
pkgrel=1
pkgdesc="Simple terminal UI for git commands"
url="https://github.com/jesseduffield/lazygit"
arch="all"
license="MIT"
+# bash: for running git commands
+depends="ncurses bash"
makedepends="go"
options="!check" # FIXME: https://github.com/jesseduffield/lazygit/issues/1009
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/jesseduffield/lazygit/archive/v$pkgver.tar.gz"
-export GOPATH="$srcdir"
-export GOFLAGS="$GOFLAGS -trimpath -mod=readonly -modcacherw"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
- go build -ldflags="-s -w" -v
+ go build -ldflags="-X main.version=$pkgver" -v
}
package() {
@@ -27,7 +30,6 @@ package() {
install -Dm0644 LICENSE -t "$pkgdir"/usr/share/licenses/"$pkgname"
}
-
sha512sums="
-e7002089194c572fffe8329bd245d4db64fb71cb73c63f07b950da845ecdc85c70c8bea682d2b4aa1c9b38f8cf5270cd24d3bb41eff8a26d31be58eddcdf41ce lazygit-0.28.2.tar.gz
+ef1d8e2394eb3230c0489e0b0c6726536649697943fa8a7cbf95e9eb600c8fe3429e72539897f04ffd3ee35905b96600c5a79174856c4e49a22fbeada668bf4e lazygit-0.41.0.tar.gz
"