aboutsummaryrefslogtreecommitdiffstats
path: root/community/lazygit/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/lazygit/APKBUILD')
-rw-r--r--community/lazygit/APKBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/community/lazygit/APKBUILD b/community/lazygit/APKBUILD
index 739dfd0c49c..12b192c3187 100644
--- a/community/lazygit/APKBUILD
+++ b/community/lazygit/APKBUILD
@@ -1,20 +1,22 @@
# Contributor: Thomas Deutsch <thomas@tuxpeople.org>
# Maintainer: Thomas Deutsch <thomas@tuxpeople.org>
pkgname=lazygit
-pkgver=0.34
-pkgrel=1
+pkgver=0.40.2
+pkgrel=3
pkgdesc="Simple terminal UI for git commands"
url="https://github.com/jesseduffield/lazygit"
arch="all"
license="MIT"
-depends="ncurses"
+# bash: for running git commands
+depends="ncurses bash"
makedepends="go"
options="!check" # FIXME: https://github.com/jesseduffield/lazygit/issues/1009
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/jesseduffield/lazygit/archive/v$pkgver.tar.gz"
-export GOPATH="$srcdir"
-export GOFLAGS="$GOFLAGS -trimpath -mod=readonly -modcacherw"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
go build -ldflags="-X main.version=$pkgver" -v
@@ -28,7 +30,6 @@ package() {
install -Dm0644 LICENSE -t "$pkgdir"/usr/share/licenses/"$pkgname"
}
-
sha512sums="
-a63dd877220c124282667acaadd2f9c55c47687e0c65caff9f61c5a6a3cecc202501fdbd3a1ee13752c8e68bbbb920b5b198459e71a44c585d594675b931d5c2 lazygit-0.34.tar.gz
+201bd09705ad48c41ed62ac061b31e62ce51a351eff5dae36a3bf5654d62fdef5d2a93e3f4ad56c0b02c70fb0e323319ed38d64c3bfef36900423983284b52c1 lazygit-0.40.2.tar.gz
"