aboutsummaryrefslogtreecommitdiffstats
path: root/community/lbreakouthd/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/lbreakouthd/APKBUILD')
-rw-r--r--community/lbreakouthd/APKBUILD27
1 files changed, 13 insertions, 14 deletions
diff --git a/community/lbreakouthd/APKBUILD b/community/lbreakouthd/APKBUILD
index 228295bd244..496a453699e 100644
--- a/community/lbreakouthd/APKBUILD
+++ b/community/lbreakouthd/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Antoni Aloy <aaloytorrens@gmail.com>
pkgname=lbreakouthd
-pkgver=1.0.10
+pkgver=1.1.4
pkgrel=0
pkgdesc="Ball-and-paddle game (LBreakout2 successor)"
url="https://lgames.sourceforge.io/LBreakoutHD/"
@@ -8,32 +8,32 @@ arch="all"
license="GPL-2.0-or-later"
depends="$pkgname-data"
makedepends="
- sdl2-dev sdl2_image-dev
- sdl2_mixer-dev sdl2_ttf-dev
+ gettext-dev
+ sdl2-dev
+ sdl2_image-dev
+ sdl2_mixer-dev
+ sdl2_ttf-dev
"
-subpackages="$pkgname-data::noarch"
+subpackages="$pkgname-lang $pkgname-data::noarch"
source="https://sourceforge.net/projects/lgames/files/lbreakouthd/lbreakouthd-$pkgver.tar.gz
0001-fix-undeclared-uint.patch
+ format-security.patch
"
options="!check" # No test suite
prepare() {
default_prepare
- update_config_guess
update_config_sub
}
-# Fails to build on builders if we enable nls (Native Language Support):
-# ERROR: gettext-tiny-dev-0.3.2-r0: trying to overwrite usr/include/libintl.h owned by musl-libintl-1.2.2-r3
-
build() {
+ LIBS="-lintl" \
./configure \
--build=$CBUILD \
--host=$CHOST \
--sysconfdir=/etc \
--localstatedir=/var/lbreakouthd \
- --prefix=/usr \
- --disable-nls
+ --prefix=/usr
make
}
@@ -43,12 +43,11 @@ package() {
data() {
pkgdesc="$pkgdesc (data files)"
- mkdir -p "$subpkgdir"/usr/share/
- mv "$pkgdir"/usr/share/lbreakouthd \
- "$subpkgdir"/usr/share/
+ amove usr/share/lbreakouthd
}
sha512sums="
-520bda4a438b749fa03acdfdb977c8e88189baf8f1820ff00ad5c607f740f9b753c1698503678ab7ad2f5d053690976026e5a6e996fe7b07af567865eab0f7fe lbreakouthd-1.0.10.tar.gz
+868e9616c3ce59a54c0578268668cdfc5952015f86d7e76d5dce51f24a0676e0c97f4faf895def0a03fd5f38b4c73ef0ef740c308557df42cb759e5b716cee0d lbreakouthd-1.1.4.tar.gz
4de6934a7840153354f54c5c6a9c14d22e3d5a76030cd33131c2511d97c363d73912d53d3581fd756ff42dec9c7d4e819056e5a2eee5d92064a88a9337abe5eb 0001-fix-undeclared-uint.patch
+1600c7cb2c655d775b08961e7752979367c218917f628682e598816e33233cea7c3450c6f03005186dc8f6411d256733da4ed93284d4517608db9167bd189ce5 format-security.patch
"