aboutsummaryrefslogtreecommitdiffstats
path: root/community/lego/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/lego/APKBUILD')
-rw-r--r--community/lego/APKBUILD36
1 files changed, 14 insertions, 22 deletions
diff --git a/community/lego/APKBUILD b/community/lego/APKBUILD
index 25d3b6335d0..9eb618d1904 100644
--- a/community/lego/APKBUILD
+++ b/community/lego/APKBUILD
@@ -1,46 +1,38 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
pkgname=lego
-pkgver=4.8.0
-pkgrel=2
+pkgver=4.16.1
+pkgrel=1
pkgdesc="Let's Encrypt client and ACME library written in Go"
url="https://github.com/go-acme/lego"
license="MIT"
arch="all !s390x" # tests fail due to network timeouts
-options="net chmod-clean" # tests need network access: https://github.com/go-acme/lego/issues/560
+options="net setcap chmod-clean" # tests need network access: https://github.com/go-acme/lego/issues/560
depends="ca-certificates"
-makedepends="go libcap"
+makedepends="go libcap-utils"
+checkdepends="tzdata"
+subpackages="$pkgname-doc"
source="https://github.com/go-acme/lego/archive/v$pkgver/lego-$pkgver.tar.gz"
-export CGO_ENABLED=0
-export GOCACHE="$srcdir/go-cache"
-export GOTMPDIR="$srcdir"
-export GOMODCACHE="$srcdir/go"
-
-case "$CARCH" in
- aarch64)
- # TestChallengeWithProxy/matching_X-Forwarded-Host_(multiple_fields)
- options="$options !check"
- ;;
- ppc64le)
- # timeout on doing stuff with a server halfway across the world
- options="$options !check"
- ;;
-esac
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
- go build -v -ldflags "-X main.version=$pkgver" -o ./bin/lego ./cmd/lego
+ go build -v -trimpath -ldflags "-X main.version=$pkgver" -o ./bin/lego ./cmd/lego
}
check() {
- go test -v ./...
+ go test ./...
}
package() {
install -Dm755 ./bin/lego "$pkgdir"/usr/bin/lego
setcap cap_net_bind_service=+ep "$pkgdir"/usr/bin/lego
+
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
sha512sums="
-8a3b64bee5bfe37ca6c138a126a52cb335b31865a9f0dfd35f19fc4c1a91b0c49f1dc3ce34fdeef348102a074ad2a733039343f365fa962cef39dfafc74c2e39 lego-4.8.0.tar.gz
+a65c661fc003cc26c13ed6b38719a0ab49a8fe8e2a18c59c84e5c974b918aaf0c55c92015d2794a17b4fe5ac31c3557a4d5e1971527441b8bdf80907fe4b90e9 lego-4.16.1.tar.gz
"