aboutsummaryrefslogtreecommitdiffstats
path: root/community/lego/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/lego/APKBUILD')
-rw-r--r--community/lego/APKBUILD35
1 files changed, 19 insertions, 16 deletions
diff --git a/community/lego/APKBUILD b/community/lego/APKBUILD
index fd41f995a24..9eb618d1904 100644
--- a/community/lego/APKBUILD
+++ b/community/lego/APKBUILD
@@ -1,35 +1,38 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
pkgname=lego
-pkgver=3.4.0
+pkgver=4.16.1
pkgrel=1
pkgdesc="Let's Encrypt client and ACME library written in Go"
url="https://github.com/go-acme/lego"
-arch="all"
license="MIT"
+arch="all !s390x" # tests fail due to network timeouts
+options="net setcap chmod-clean" # tests need network access: https://github.com/go-acme/lego/issues/560
depends="ca-certificates"
-makedepends="go libcap"
-source="$pkgname-$pkgver.tar.gz::https://github.com/go-acme/lego/archive/v$pkgver.tar.gz"
+makedepends="go libcap-utils"
+checkdepends="tzdata"
+subpackages="$pkgname-doc"
+source="https://github.com/go-acme/lego/archive/v$pkgver/lego-$pkgver.tar.gz"
-export GOPATH="$srcdir"
-export CGO_ENABLED=0
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
- go build -v -ldflags "-X main.version=$pkgver" -o ./bin/lego ./cmd/lego
+ go build -v -trimpath -ldflags "-X main.version=$pkgver" -o ./bin/lego ./cmd/lego
+}
+
+check() {
+ go test ./...
}
package() {
install -Dm755 ./bin/lego "$pkgdir"/usr/bin/lego
setcap cap_net_bind_service=+ep "$pkgdir"/usr/bin/lego
-}
-cleanup_srcdir() {
- go clean -modcache
- default_cleanup_srcdir
-}
-
-check() {
- go test -v -cover ./...
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
-sha512sums="ec4613e757920b9671e9749738883fcf95bb179706a514141a3e593c244099afe264813ee2b233c2c0dcf7be48bd96393dc7847e8b756c9e67e4c62ae5e9aa0a lego-3.4.0.tar.gz"
+sha512sums="
+a65c661fc003cc26c13ed6b38719a0ab49a8fe8e2a18c59c84e5c974b918aaf0c55c92015d2794a17b4fe5ac31c3557a4d5e1971527441b8bdf80907fe4b90e9 lego-4.16.1.tar.gz
+"