aboutsummaryrefslogtreecommitdiffstats
path: root/community/lego/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/lego/APKBUILD')
-rw-r--r--community/lego/APKBUILD28
1 files changed, 13 insertions, 15 deletions
diff --git a/community/lego/APKBUILD b/community/lego/APKBUILD
index 24448cdcbd8..e0529628c6b 100644
--- a/community/lego/APKBUILD
+++ b/community/lego/APKBUILD
@@ -1,40 +1,38 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
pkgname=lego
-pkgver=4.5.3
+pkgver=4.16.1
pkgrel=0
pkgdesc="Let's Encrypt client and ACME library written in Go"
url="https://github.com/go-acme/lego"
license="MIT"
arch="all !s390x" # tests fail due to network timeouts
-options="net chmod-clean" # tests need network access: https://github.com/go-acme/lego/issues/560
+options="net setcap chmod-clean" # tests need network access: https://github.com/go-acme/lego/issues/560
depends="ca-certificates"
-makedepends="go libcap"
+makedepends="go libcap-utils"
+checkdepends="tzdata"
+subpackages="$pkgname-doc"
source="https://github.com/go-acme/lego/archive/v$pkgver/lego-$pkgver.tar.gz"
-export GOPATH="$srcdir"
-export CGO_ENABLED=0
-
-case "$CARCH" in
- aarch64)
- # TestChallengeWithProxy/matching_X-Forwarded-Host_(multiple_fields)
- options="$options !check"
- ;;
-esac
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
- go build -v -ldflags "-X main.version=$pkgver" -o ./bin/lego ./cmd/lego
+ go build -v -trimpath -ldflags "-X main.version=$pkgver" -o ./bin/lego ./cmd/lego
}
check() {
- go test -v ./...
+ go test ./...
}
package() {
install -Dm755 ./bin/lego "$pkgdir"/usr/bin/lego
setcap cap_net_bind_service=+ep "$pkgdir"/usr/bin/lego
+
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
sha512sums="
-0de7a9078254a735a7802fb389673bfc4333a048a0d2211a0f76f4469a113ffcd6b0b63e574bdeb3f05c3140a310ce263a75d6ced71597f7b962518d8a762227 lego-4.5.3.tar.gz
+a65c661fc003cc26c13ed6b38719a0ab49a8fe8e2a18c59c84e5c974b918aaf0c55c92015d2794a17b4fe5ac31c3557a4d5e1971527441b8bdf80907fe4b90e9 lego-4.16.1.tar.gz
"