aboutsummaryrefslogtreecommitdiffstats
path: root/community/leiningen/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/leiningen/APKBUILD')
-rw-r--r--community/leiningen/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/community/leiningen/APKBUILD b/community/leiningen/APKBUILD
new file mode 100644
index 00000000000..ca84a8ed69d
--- /dev/null
+++ b/community/leiningen/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Will Sinatra <wpsinatra@gmail.com>
+# Maintainer: Will Sinatra <wpsinatra@gmail.com>
+pkgname=leiningen
+pkgver=2.11.2
+pkgrel=0
+pkgdesc="Automate Clojure Projects"
+options="!check" #No Checks
+url="https://leiningen.org/"
+arch="noarch !riscv64" # blocked by java-jdk
+license="EPL-1.0"
+depends="bash java-jdk"
+subpackages="$pkgname-doc
+ $pkgname-bash-completion
+ $pkgname-zsh-completion
+ "
+source="$pkgname-$pkgver.tar.gz::https://github.com/technomancy/leiningen/archive/refs/tags/$pkgver.tar.gz
+ https://github.com/technomancy/leiningen/releases/download/$pkgver/leiningen-$pkgver-standalone.jar"
+
+package() {
+ install -Dm755 "$builddir/bin/lein-pkg" \
+ "$pkgdir/usr/bin/lein"
+
+ install -Dm644 "$builddir/doc/lein.1" \
+ "$pkgdir/usr/share/man/man1/lein.1"
+
+ install -Dm 644 "$srcdir/leiningen-$pkgver-standalone.jar" \
+ "$pkgdir/usr/share/java/leiningen-$pkgver-standalone.jar"
+
+ install -Dm644 bash_completion.bash \
+ "$pkgdir"/usr/share/bash-completion/completions/lein
+ install -Dm644 zsh_completion.zsh \
+ "$pkgdir"/usr/share/zsh/site-functions/_lein
+}
+
+sha512sums="
+fc4dd871712e0fc5957843f04e73b6308d010f14bfe9663de4d4741ebafa193fafd6ad021c39258765dcff41472125210a45fdcfebe003df386064c4310e0809 leiningen-2.11.2.tar.gz
+a49e82acccdaae4f619796adf1ef9d0cfc4998c01f4c918520bb3f757b9f7808fb5c65241f79aea730d1e90181c9c2983b7219ef0893103f7abcedf94afcafd5 leiningen-2.11.2-standalone.jar
+"