aboutsummaryrefslogtreecommitdiffstats
path: root/community/lensfun/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/lensfun/APKBUILD')
-rw-r--r--community/lensfun/APKBUILD63
1 files changed, 44 insertions, 19 deletions
diff --git a/community/lensfun/APKBUILD b/community/lensfun/APKBUILD
index ebe239df8e1..6fd424b050e 100644
--- a/community/lensfun/APKBUILD
+++ b/community/lensfun/APKBUILD
@@ -1,34 +1,59 @@
# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
pkgname=lensfun
-pkgver=0.3.2
-pkgrel=2
+pkgver=0.3.4
+pkgrel=1
pkgdesc="Image manipulation library to rectify lens defects"
-url="http://lensfun.sourceforge.net/"
+url="https://lensfun.github.io/"
arch="all"
license="LGPL-3.0-or-later"
-makedepends="py3-docutils cmake doxygen libpng glib-dev"
-subpackages="$pkgname-dev"
-source="https://downloads.sourceforge.net/project/lensfun/$pkgver/lensfun-$pkgver.tar.gz"
+makedepends="
+ cmake
+ doxygen
+ glib-dev
+ libpng-dev
+ py3-docutils
+ py3-setuptools
+ py3-wheel
+ samurai
+ "
+subpackages="$pkgname-dev $pkgname-doc $pkgname-tools py3-$pkgname-pyc py3-$pkgname:py3:noarch"
+source="$pkgname-$pkgver.tar.gz::https://github.com/lensfun/lensfun/archive/refs/tags/v$pkgver.tar.gz"
build() {
- local opts=""
- case "$CARCH" in
- x86*) ;;
- *) opts="-DBUILD_FOR_SSE=OFF -DBUILD_FOR_SSE2=OFF";;
- esac
-
- cmake \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DBUILD_DOC=ON \
+ -DBUILD_LENSTOOL=ON \
+ -DBUILD_TESTS=ON \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- $opts
+ -DCMAKE_INSTALL_LIBDIR=lib
+
+ cmake --build build
+}
- make all
+check() {
+ cd build
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
+ cd build/apps
+ python3 setup.py install --root="$pkgdir" --skip-build
+}
+
+tools() {
+ pkgdesc="$pkgdesc (extra tools)"
+ amove usr/bin
+}
+
+py3() {
+ depends="python3"
+ pkgdesc="$pkgdesc (python bindings)"
+ amove usr/lib/python3*
}
-sha512sums="9c6f546fa70e6dc692e66ef378447345be6d3383812934780d326d772d775c1918cbf3447cd91c067655044cf659025763bf47ba2d938a82a3c2de4d60127446 lensfun-0.3.2.tar.gz"
+sha512sums="
+4db9a08d51ba50c7c2ff528d380bb28e34698b2bb5c40e5f3deeaa5544c888ac7e0f638bbc3f33a4f75dbb67e0425ca36ce6d8cd1d8c043a4173a2df47de08c6 lensfun-0.3.4.tar.gz
+"