aboutsummaryrefslogtreecommitdiffstats
path: root/community/libaccounts-glib/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libaccounts-glib/APKBUILD')
-rw-r--r--community/libaccounts-glib/APKBUILD29
1 files changed, 22 insertions, 7 deletions
diff --git a/community/libaccounts-glib/APKBUILD b/community/libaccounts-glib/APKBUILD
index 26ccfa4034e..2ebf6f065e2 100644
--- a/community/libaccounts-glib/APKBUILD
+++ b/community/libaccounts-glib/APKBUILD
@@ -1,14 +1,27 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=libaccounts-glib
-pkgver=1.25
-pkgrel=2
+pkgver=1.27
+pkgrel=0
+pkgdesc="GLib-based client library for the accounts database"
arch="all"
url="https://gitlab.com/accounts-sso/libaccounts-glib"
-pkgdesc="GLib-based client library for the accounts database"
license="LGPL-2.1-or-later"
-depends_dev="libxml2-dev sqlite-dev check-dev py3-gobject3 gobject-introspection-dev"
-makedepends="$depends_dev meson ninja vala python3 gtk-doc glib-dev"
+depends_dev="
+ check-dev
+ gobject-introspection-dev
+ libxml2-dev
+ py3-gobject3
+ sqlite-dev
+ "
+makedepends="$depends_dev
+ glib-dev
+ gtk-doc
+ meson
+ ninja
+ python3
+ vala
+ "
source="https://gitlab.com/accounts-sso/libaccounts-glib/-/archive/VERSION_$pkgver/libaccounts-glib-VERSION_$pkgver.tar.gz"
subpackages="$pkgname-dev $pkgname-doc"
options="!check" # Requires a systemd feature
@@ -16,7 +29,7 @@ builddir="$srcdir/$pkgname-VERSION_$pkgver"
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
@@ -27,4 +40,6 @@ package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="cc8b493d246f99300ee614fed93258378ecdbe9c518a958a59827ee8f74559b1ee3683acfb85f59aa91390275497fb35041da2be47f27f24f96e1efd5d6d2e20 libaccounts-glib-VERSION_1.25.tar.gz"
+sha512sums="
+cdccc1b72c894c8db95d409624afbfc77818536caa2c0c916e8802f4c3763aab9fe98c9153b00d2559d2382f248727251a65b1ad2baef28d4d0d1016fb88ccfe libaccounts-glib-VERSION_1.27.tar.gz
+"