aboutsummaryrefslogtreecommitdiffstats
path: root/community/libarchive-qt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libarchive-qt/APKBUILD')
-rw-r--r--community/libarchive-qt/APKBUILD28
1 files changed, 12 insertions, 16 deletions
diff --git a/community/libarchive-qt/APKBUILD b/community/libarchive-qt/APKBUILD
index 64762862c0f..38acffcba34 100644
--- a/community/libarchive-qt/APKBUILD
+++ b/community/libarchive-qt/APKBUILD
@@ -1,18 +1,17 @@
-# Contributor:
# Maintainer:
pkgname=libarchive-qt
-pkgver=2.0.6
-pkgrel=0
+pkgver=2.0.8
+pkgrel=2
pkgdesc="Qt based archiving solution with libarchive backend"
url="https://gitlab.com/marcusbritanicus/libarchive-qt"
-options="!check"
arch="all"
license="LGPL-3.0-or-later"
depends_dev="qt5-qtbase-dev xz-dev libarchive-dev zlib-dev bzip2-dev"
-makedepends="$depends_dev cmake lzip"
+makedepends="$depends_dev lzip meson"
subpackages="$pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::https://gitlab.com/marcusbritanicus/libarchive-qt/-/archive/v$pkgver/libarchive-qt-v$pkgver.tar.gz"
+source="https://gitlab.com/marcusbritanicus/libarchive-qt/-/archive/v$pkgver/libarchive-qt-v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-v$pkgver"
+options="!check" # no tests
prepare() {
default_prepare
@@ -22,20 +21,17 @@ prepare() {
}
build() {
- if [ "$CBUILD" != "$CHOST" ]; then
- CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
- fi
- cmake -B build \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=None \
- $CMAKE_CROSSOPTS .
- cmake --build build
+ abuild-meson \
+ -Duse_qt_version=qt5 \
+ -Dinstall_static=false \
+ . output
+ meson compile -C output
}
package() {
- DESTDIR="$pkgdir" cmake --install build
+ DESTDIR="$pkgdir" meson install -C output
}
sha512sums="
-aa25952a585724579c4f8885414b7f343d958f576bfd8278c09cdec0f8ca776bb6480b5e3e545c33adbbd3c980ff20ce36ee37cc754df2971e77b04292a05828 libarchive-qt-2.0.6.tar.gz
+6853862ca588b3ba9ead54d3a48f6d1c8f8273f4ceaf20c4c55acd9df02ab52012044f8c57505a078ac0589df5af568f649e39c740ba398f2fef65fc505fef3e libarchive-qt-v2.0.8.tar.gz
"