aboutsummaryrefslogtreecommitdiffstats
path: root/community/libarchive-qt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libarchive-qt/APKBUILD')
-rw-r--r--community/libarchive-qt/APKBUILD35
1 files changed, 23 insertions, 12 deletions
diff --git a/community/libarchive-qt/APKBUILD b/community/libarchive-qt/APKBUILD
index e5a22479955..38acffcba34 100644
--- a/community/libarchive-qt/APKBUILD
+++ b/community/libarchive-qt/APKBUILD
@@ -1,26 +1,37 @@
-# Contributor:
# Maintainer:
pkgname=libarchive-qt
-pkgver=2.0.4
-pkgrel=0
+pkgver=2.0.8
+pkgrel=2
pkgdesc="Qt based archiving solution with libarchive backend"
url="https://gitlab.com/marcusbritanicus/libarchive-qt"
-options="!check"
-arch="" # fails to build
+arch="all"
license="LGPL-3.0-or-later"
depends_dev="qt5-qtbase-dev xz-dev libarchive-dev zlib-dev bzip2-dev"
-makedepends="$depends_dev lzip"
+makedepends="$depends_dev lzip meson"
subpackages="$pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::https://gitlab.com/marcusbritanicus/libarchive-qt/-/archive/v$pkgver/libarchive-qt-v$pkgver.tar.gz"
+source="https://gitlab.com/marcusbritanicus/libarchive-qt/-/archive/v$pkgver/libarchive-qt-v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-v$pkgver"
+options="!check" # no tests
+
+prepare() {
+ default_prepare
+
+ # Binary executable in the repo, WTF?!
+ rm -rf archiver/archiver
+}
build() {
- qmake-qt5
- make
+ abuild-meson \
+ -Duse_qt_version=qt5 \
+ -Dinstall_static=false \
+ . output
+ meson compile -C output
}
package() {
- INSTALL_ROOT="$pkgdir" make install
- rm -f "$pkgdir"/usr/lib/*.a
+ DESTDIR="$pkgdir" meson install -C output
}
-sha512sums="37b8719f689f6670543c41ebe1a1e73f4cc1fda48415103708832a94aeee2b27753c6e17e60e6849c05f2a98486e7e819a7d15faf284234bd47c18feb9565893 libarchive-qt-2.0.4.tar.gz"
+
+sha512sums="
+6853862ca588b3ba9ead54d3a48f6d1c8f8273f4ceaf20c4c55acd9df02ab52012044f8c57505a078ac0589df5af568f649e39c740ba398f2fef65fc505fef3e libarchive-qt-v2.0.8.tar.gz
+"