aboutsummaryrefslogtreecommitdiffstats
path: root/community/libarcus/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libarcus/APKBUILD')
-rw-r--r--community/libarcus/APKBUILD36
1 files changed, 18 insertions, 18 deletions
diff --git a/community/libarcus/APKBUILD b/community/libarcus/APKBUILD
index 32ae1164e7d..00597e1f12b 100644
--- a/community/libarcus/APKBUILD
+++ b/community/libarcus/APKBUILD
@@ -1,9 +1,11 @@
# Contributor: Aiden Grossman <agrossman154@yahoo.com>
# Maintainer: Aiden Grossman <agrossman154@yahoo.com>
pkgname=libarcus
-# Needs to be upgraded in sync with the curaengine aport
-pkgver=4.13.1
-pkgrel=1
+# Needs to be upgraded in sync with the py3-arcus aport
+# Should be in sync with the CuraEngine aport, but sometimes
+# upstream doesn't version them together
+pkgver=5.2.2
+pkgrel=4
pkgdesc="Communication library for Cura"
url="https://github.com/Ultimaker/libArcus"
arch="all"
@@ -11,22 +13,25 @@ license="LGPL-3.0-or-later"
makedepends="
cmake
protobuf-dev
- py3-sip4-dev
+ py3-sip
python3-dev
+ samurai
"
-subpackages="$pkgname-dev py3-$pkgname:_py"
+subpackages="$pkgname-dev"
options="!check" # no test suite
source="https://github.com/Ultimaker/libArcus/archive/$pkgver/libArcus-$pkgver.tar.gz
- protobuf.patch
- "
+ cmake-build.patch
+ ArcusConfig.patch"
builddir="$srcdir/libArcus-$pkgver"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_PYTHON=ON
+ -DCMAKE_INSTALL_INCLUDEDIR=/usr/include \
+ -DBUILD_SHARED_LIBS=ON \
+ -DARCUS_VERSION=$pkgver
cmake --build build
}
@@ -34,13 +39,8 @@ package() {
DESTDIR="$pkgdir" cmake --install build
}
-_py() {
- pkgdesc="Python bindings for libarcus"
- depends="python3"
- amove usr/lib/python3*
-}
-
sha512sums="
-ffb14595f23c47f71082b994eae01471f45e2e9e1ae9a8ad01df577b9445594c30173388beab016a92be9723638ca6e46b5cecddddc6adc97e9d212fc0fa23fa libArcus-4.13.1.tar.gz
-6b1994507776148a07f8adfa56590259bd6142a780c7660ed7b1c007f79a9399a0914565b66e9422597ae052f0988c3ae09a20f096902f3a9e2daee20c42d363 protobuf.patch
+d33fb7dae1fef4d99bad7a165b02767b9e8d1f48dc3e2d4fe635a56019f294c9703762421efcf3bc4e20fab8c6c9e9816bba9ddb4ecc85c0303cd027e39dede1 libArcus-5.2.2.tar.gz
+87c8d80afca0be287d8686e3a2133753f95dbc361fbffda8f0cfd63a8890fff9a9374e00bb6d42040ef23def9a116126e0d5a1a001d596dc74934292ed0791d7 cmake-build.patch
+9a058e240014de0c6698b3cc38a4b5064455adc0901fad05c0f78b67ae6cf82e9ca5dd4e74a8cc95d8915fd57b10336c7974b19f061e5a53a28d7b63f80c4851 ArcusConfig.patch
"