aboutsummaryrefslogtreecommitdiffstats
path: root/community/libayatana-appindicator/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libayatana-appindicator/APKBUILD')
-rw-r--r--community/libayatana-appindicator/APKBUILD18
1 files changed, 7 insertions, 11 deletions
diff --git a/community/libayatana-appindicator/APKBUILD b/community/libayatana-appindicator/APKBUILD
index 89e8b0068b7..7e7254d477d 100644
--- a/community/libayatana-appindicator/APKBUILD
+++ b/community/libayatana-appindicator/APKBUILD
@@ -1,11 +1,11 @@
# Contributor: Luca Weiss <luca@z3ntu.xyz>
# Maintainer: Luca Weiss <luca@z3ntu.xyz>
pkgname=libayatana-appindicator
-pkgver=0.5.90
+pkgver=0.5.93
pkgrel=0
pkgdesc="Ayatana Application Indicators Shared Library"
url="https://github.com/AyatanaIndicators/libayatana-appindicator"
-arch="all !s390x" # tests fail on builders
+arch="all"
license="LGPL-3.0-only"
makedepends="
cmake
@@ -15,20 +15,18 @@ makedepends="
gtk+3.0-dev
libayatana-indicator-dev
libdbusmenu-gtk3-dev
+ samurai
vala
"
checkdepends="dbus-test-runner xvfb-run"
subpackages="$pkgname-dev"
-source="https://github.com/AyatanaIndicators/libayatana-appindicator/archive/$pkgver/libayatana-appindicator-$pkgver.tar.gz
- 0001-Fix-build-with-musl-libc.patch
- tests-bash.patch
- "
+source="https://github.com/AyatanaIndicators/libayatana-appindicator/archive/$pkgver/libayatana-appindicator-$pkgver.tar.gz"
build() {
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
- cmake -B build \
+ cmake -B build -G Ninja \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=True \
@@ -41,7 +39,7 @@ build() {
check() {
cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -j1
}
package() {
@@ -49,7 +47,5 @@ package() {
}
sha512sums="
-cdef7e7ff96561e2577752379b3581871fcba1d79dc3ba05c5b2cf28708bb4af804ad79af6b5d4fc6920de5cdd875b1d32bfc994012cee4239387879380034dd libayatana-appindicator-0.5.90.tar.gz
-db683d078d56b8217ed652f6fc3bb51f9eed0d50145f440c30988fabbb7be4197344ca2a4e7f569ff9ea654126fb15e9b57b2a5c3573cfdaed558d7de0507aef 0001-Fix-build-with-musl-libc.patch
-2d93715ac616e4e7ab83ce2de7a02e572ebab81470b41f9198b443a226388a761e1dc4b67c1cf4b452b9497e72801ae1998c642e1d950bb2a2c5780850e29126 tests-bash.patch
+0477555de74d98a52d6415f5a5a2550aede1db0b54e9df3e761a0ad697b753b5b81827324df860c5ef0fd38c903b07dd8f4bf3129a2bb764d77f9028b03570b4 libayatana-appindicator-0.5.93.tar.gz
"