aboutsummaryrefslogtreecommitdiffstats
path: root/community/libb2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libb2/APKBUILD')
-rw-r--r--community/libb2/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/community/libb2/APKBUILD b/community/libb2/APKBUILD
new file mode 100644
index 00000000000..987c4a37826
--- /dev/null
+++ b/community/libb2/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=libb2
+pkgver=0.98.1
+pkgrel=3
+pkgdesc="C library providing BLAKE2b, BLAKE2s, BLAKE2bp, BLAKE2sp"
+url="https://blake2.net/"
+arch="all"
+license="CC0-1.0"
+subpackages="$pkgname-dev"
+source="https://github.com/BLAKE2/libb2/releases/download/v$pkgver/libb2-$pkgver.tar.gz"
+
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ case "$CARCH" in
+ x86*)
+ _fat_runtime=yes
+ ;;
+ *)
+ _fat_runtime=no
+ ;;
+ esac
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-fat=$_fat_runtime
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="
+e760972173bb9ff3562843882abbe9042af09da63f37a5706921381be2d64cc4d333aec65e1e676d5a45ace913417536a1dc188c90b394c2f7b9cae654dbb108 libb2-0.98.1.tar.gz
+"