aboutsummaryrefslogtreecommitdiffstats
path: root/community/libbs2b/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libbs2b/APKBUILD')
-rw-r--r--community/libbs2b/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/community/libbs2b/APKBUILD b/community/libbs2b/APKBUILD
new file mode 100644
index 00000000000..3b5caa6c976
--- /dev/null
+++ b/community/libbs2b/APKBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
+pkgname=libbs2b
+pkgver=3.1.0
+pkgrel=3
+pkgdesc="Unofficial fork of Bauer stereophonic-to-binaural DSP library"
+url="https://github.com/alexmarsev/libbs2b"
+arch="all"
+license="MIT"
+options="!check" # no testsuite
+makedepends="autoconf automake libsndfile-dev libtool"
+subpackages="$pkgname-dev $pkgname-tools"
+source="https://downloads.sourceforge.net/sourceforge/bs2b/libbs2b-$pkgver.tar.gz
+ format-security.patch
+ "
+
+prepare() {
+ default_prepare
+ # old configure script with now-nonexistent dist-lzma definition
+ sed -i 's/dist-lzma//' configure.ac
+ autoreconf -fi
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr
+
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+tools() {
+ pkgdesc="$pkgdesc (tools)"
+ amove usr/bin
+}
+
+sha512sums="
+3fba925fb07b28183f3bf3abe31c13915cb8c3fdd2a7c567819ab912a61463fd5769c4644faa3a114bd68ed7cd51d6fbf5304ab83a02f1004ae34fb93a748fbb libbs2b-3.1.0.tar.gz
+98adf03a42642efcdd869a2822b42d147186391cb33a98de36bcd3ebca3eb99a293c16d4726f579d602aebb2bd82c8957a68316a7250687aaa67dd5fd90bb3a3 format-security.patch
+"