aboutsummaryrefslogtreecommitdiffstats
path: root/community/libbytesize/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libbytesize/APKBUILD')
-rw-r--r--community/libbytesize/APKBUILD35
1 files changed, 23 insertions, 12 deletions
diff --git a/community/libbytesize/APKBUILD b/community/libbytesize/APKBUILD
index a06e70d2aed..95e6be897e4 100644
--- a/community/libbytesize/APKBUILD
+++ b/community/libbytesize/APKBUILD
@@ -2,21 +2,31 @@
# Contributor: André Klitzing <aklitzing@gmail.com>
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=libbytesize
-pkgver=2.6
-pkgrel=0
+pkgver=2.10
+pkgrel=2
pkgdesc="Library for working with arbitrary big sizes in bytes"
options="!check" # Tests require dealing with locales
-url="https://github.com/rhinstaller/libbytesize"
+url="https://github.com/storaged-project/libbytesize"
arch="all"
license="LGPL-2.1-or-later"
makedepends="gettext-dev gmp-dev mpfr-dev pcre2-dev python3"
checkdepends="bash py3-six"
-subpackages="$pkgname-dev $pkgname-lang py-$pkgname:_py:noarch $pkgname-doc
- $pkgname-tools:_tools:noarch"
+subpackages="
+ $pkgname-dev
+ $pkgname-lang
+ py3-$pkgname:_py:noarch
+ $pkgname-doc
+ $pkgname-tools:_tools:noarch
+ "
source="https://github.com/storaged-project/libbytesize/releases/download/$pkgver/libbytesize-$pkgver.tar.gz"
build() {
- CFLAGS="$CFLAGS -lintl" ./configure --prefix=/usr
+ CFLAGS="$CFLAGS -flto=auto -lintl" \
+ ./configure \
+ --host=$CHOST \
+ --build=$CBUILD \
+ --prefix=/usr \
+ --disable-dependency-tracking
make
}
@@ -33,20 +43,21 @@ package() {
_py() {
pkgdesc="Python bindings for $pkgname"
- depends="python3 py3-six"
+ depends="python3"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
+ replaces="py-libbytesize" # Backwards compatibility
+ provides="py-libbytesize=$pkgver-r$pkgrel" # Backwards compatibility
+
+ amove usr/lib/python*
}
_tools() {
pkgdesc="Tools for libbytesize"
depends="py-$pkgname"
- mkdir -p "$subpkgdir"/usr/bin
- mv "$pkgdir"/usr/bin/* "$subpkgdir"/usr/bin
+ amove usr/bin
}
sha512sums="
-f6e72b763216c54c08318d090d604791c61cd5a3e683ffbe6e9d01de850661bd4e8a3adeb85c6fd0fb60244e2e128292cbae06c0aa2d1fe9f34104e64af8210e libbytesize-2.6.tar.gz
+9e52b9a756a5b4ee6e23a7a20fd0c6ca2a65ff31f38ddc7545d6838fe9a3da0ee0bd7491cb268f071c950fbeb8d65c707423d285cc3548038b3a2d3aa7f0de48 libbytesize-2.10.tar.gz
"