aboutsummaryrefslogtreecommitdiffstats
path: root/community/libbytesize/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libbytesize/APKBUILD')
-rw-r--r--community/libbytesize/APKBUILD28
1 files changed, 17 insertions, 11 deletions
diff --git a/community/libbytesize/APKBUILD b/community/libbytesize/APKBUILD
index aee7f485388..52c8e064d02 100644
--- a/community/libbytesize/APKBUILD
+++ b/community/libbytesize/APKBUILD
@@ -2,11 +2,11 @@
# Contributor: André Klitzing <aklitzing@gmail.com>
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=libbytesize
-pkgver=2.7
-pkgrel=0
+pkgver=2.10
+pkgrel=3
pkgdesc="Library for working with arbitrary big sizes in bytes"
options="!check" # Tests require dealing with locales
-url="https://github.com/rhinstaller/libbytesize"
+url="https://github.com/storaged-project/libbytesize"
arch="all"
license="LGPL-2.1-or-later"
makedepends="gettext-dev gmp-dev mpfr-dev pcre2-dev python3"
@@ -14,14 +14,19 @@ checkdepends="bash py3-six"
subpackages="
$pkgname-dev
$pkgname-lang
- py-$pkgname:_py:noarch
+ py3-$pkgname:_py:noarch
$pkgname-doc
$pkgname-tools:_tools:noarch
"
source="https://github.com/storaged-project/libbytesize/releases/download/$pkgver/libbytesize-$pkgver.tar.gz"
build() {
- CFLAGS="$CFLAGS -lintl" ./configure --prefix=/usr
+ CFLAGS="$CFLAGS -flto=auto -lintl" \
+ ./configure \
+ --host=$CHOST \
+ --build=$CBUILD \
+ --prefix=/usr \
+ --disable-dependency-tracking
make
}
@@ -38,20 +43,21 @@ package() {
_py() {
pkgdesc="Python bindings for $pkgname"
- depends="python3 py3-six"
+ depends="python3"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
+ replaces="py-libbytesize" # Backwards compatibility
+ provides="py-libbytesize=$pkgver-r$pkgrel" # Backwards compatibility
+
+ amove usr/lib/python*
}
_tools() {
pkgdesc="Tools for libbytesize"
depends="py-$pkgname"
- mkdir -p "$subpkgdir"/usr/bin
- mv "$pkgdir"/usr/bin/* "$subpkgdir"/usr/bin
+ amove usr/bin
}
sha512sums="
-3f2bdebad1e145227d7c81b25b8832ab9f984513c35d81254f68c0cb50b1883f3b96fbb258d7c8223fb284d79dc4ec8b01beae3f7687cded629b269ef5b7210e libbytesize-2.7.tar.gz
+9e52b9a756a5b4ee6e23a7a20fd0c6ca2a65ff31f38ddc7545d6838fe9a3da0ee0bd7491cb268f071c950fbeb8d65c707423d285cc3548038b3a2d3aa7f0de48 libbytesize-2.10.tar.gz
"