aboutsummaryrefslogtreecommitdiffstats
path: root/community/libcdr/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libcdr/APKBUILD')
-rw-r--r--community/libcdr/APKBUILD13
1 files changed, 4 insertions, 9 deletions
diff --git a/community/libcdr/APKBUILD b/community/libcdr/APKBUILD
index 01290865d40..449e66db3ac 100644
--- a/community/libcdr/APKBUILD
+++ b/community/libcdr/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=libcdr
-pkgver=0.1.5
-pkgrel=1
+pkgver=0.1.7
+pkgrel=12
pkgdesc="Import filter and tools for Corel DRAW files"
url="https://wiki.documentfoundation.org/DLP/Libraries/libcdr"
arch="all"
@@ -10,9 +10,7 @@ license="MPL-2.0"
depends_dev="boost-dev"
makedepends="$depends_dev doxygen icu-dev lcms2-dev zlib-dev librevenge-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
-source="https://dev-www.libreoffice.org/src/$pkgname/$pkgname-$pkgver.tar.xz"
-
-builddir="$srcdir/$pkgname-$pkgver"
+source="https://dev-www.libreoffice.org/src/libcdr/libcdr-$pkgver.tar.xz"
prepare() {
default_prepare
@@ -20,7 +18,6 @@ prepare() {
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -33,12 +30,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
@@ -47,4 +42,4 @@ tools() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr
}
-sha512sums="e985389b0cbad65dbfa9f59d7f9dba55f1684f63e852f9acca9abb863cdaab17072e761b48dca690673360d643686b5e9bc9878530f0a3a8b5b98d917f892cf0 libcdr-0.1.5.tar.xz"
+sha512sums="9af327fcf9f3f3ef1c446e92f4d2ff06ebaccb54d4c65b021960a212bf416f7098006324625f3e1c00500597eaa9da39832cc27b83a6cd593e97b76b1eb63d38 libcdr-0.1.7.tar.xz"