aboutsummaryrefslogtreecommitdiffstats
path: root/community/libchewing/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libchewing/APKBUILD')
-rw-r--r--community/libchewing/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/libchewing/APKBUILD b/community/libchewing/APKBUILD
new file mode 100644
index 00000000000..090a516bb86
--- /dev/null
+++ b/community/libchewing/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Luca Weiss <luca@z3ntu.xyz>
+# Maintainer: Celeste <cielesti@protonmail.com>
+pkgname=libchewing
+pkgver=0.6.0
+pkgrel=1
+pkgdesc="Intelligent Chinese phonetic input method"
+url="https://chewing.im/"
+arch="all"
+license="LGPL-2.1-only"
+makedepends="cmake samurai sqlite-dev"
+subpackages="$pkgname-dev"
+source="https://github.com/chewing/libchewing/releases/download/v$pkgver/libchewing-$pkgver.tar.xz"
+
+build() {
+ cmake -B build -G Ninja \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=ON \
+ -DCMAKE_BUILD_TYPE=None
+ cmake --build build
+}
+
+check() {
+ # parallel testing is broken (https://github.com/chewing/libchewing/issues/293)
+ ctest --test-dir build --output-on-failure -j1
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}
+
+sha512sums="
+9df8587061d0f283d2580d03df73472fa0b545db22f52b73606f5b51f5c23051552d5984b49ad509e5464cb6d2743d6862207dcefffc406bcda44d9e3ae9c057 libchewing-0.6.0.tar.xz
+"