aboutsummaryrefslogtreecommitdiffstats
path: root/community/libcloudproviders/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libcloudproviders/APKBUILD')
-rw-r--r--community/libcloudproviders/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/libcloudproviders/APKBUILD b/community/libcloudproviders/APKBUILD
new file mode 100644
index 00000000000..c29dc27498d
--- /dev/null
+++ b/community/libcloudproviders/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Krassy Boykinov <kboykinov@teamcentrixx.com>
+pkgname=libcloudproviders
+pkgver=0.3.6
+pkgrel=0
+pkgdesc="DBus API that allows cloud storage sync clients to expose their services"
+url="https://gitlab.gnome.org/World/libcloudproviders"
+arch="all"
+license="LGPL-3.0-or-later"
+makedepends="
+ gobject-introspection-dev
+ meson
+ vala
+ "
+checkdepends="dbus"
+subpackages="$pkgname-dev"
+source="https://gitlab.gnome.org/World/libcloudproviders/-/archive/$pkgver/libcloudproviders-$pkgver.tar.gz"
+options="!check" # no tests
+
+build() {
+ abuild-meson \
+ -Db_lto=true \
+ . output
+ meson compile -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+}
+
+sha512sums="
+4cad5f4cf503da8fd95af07a1e376cefd4245c49ff176904551b8d6a304eb26a6409b8b2ed035fe5e1e9b772b59848c3a9a332543955fbe4c2dbcf461209317e libcloudproviders-0.3.6.tar.gz
+"