aboutsummaryrefslogtreecommitdiffstats
path: root/community/libcoro
diff options
context:
space:
mode:
Diffstat (limited to 'community/libcoro')
-rw-r--r--community/libcoro/APKBUILD6
1 files changed, 0 insertions, 6 deletions
diff --git a/community/libcoro/APKBUILD b/community/libcoro/APKBUILD
index 0a5d591f13d..823df938936 100644
--- a/community/libcoro/APKBUILD
+++ b/community/libcoro/APKBUILD
@@ -11,7 +11,6 @@ makedepends="cvs gzip musl-dev"
subpackages="$pkgname-dev"
source="https://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz
test.c"
-builddir="$srcdir/$pkgname-$pkgver"
_cvsurl="cvs.schmorp.de/schmorpforge"
_cvstag="rel-${pkgver/./_}"
@@ -40,8 +39,6 @@ prepare() {
}
build() {
- cd "$builddir"
-
CFLAGS="-fPIC -pedantic -Wall"
case "$CARCH" in
x86*) CFLAGS="$CFLAGS -DCORO_ASM";;
@@ -62,13 +59,10 @@ build() {
}
check() {
- cd "$builddir"
LD_LIBRARY_PATH=. ./test
}
package() {
- cd "$builddir"
-
local abiver=$(sed -En 's/#define\s*CORO_VERSION\s*(\d+)/\1/p' coro.h)
local soname="libcoro.so.$abiver"