aboutsummaryrefslogtreecommitdiffstats
path: root/community/libcsys/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libcsys/APKBUILD')
-rw-r--r--community/libcsys/APKBUILD29
1 files changed, 18 insertions, 11 deletions
diff --git a/community/libcsys/APKBUILD b/community/libcsys/APKBUILD
index 65182f5a686..4f66127fa43 100644
--- a/community/libcsys/APKBUILD
+++ b/community/libcsys/APKBUILD
@@ -1,28 +1,35 @@
# Contributor: rahmanshaber <rahmanshaber@yahoo.com>
# Maintainer: rahmanshaber <rahmanshaber@yahoo.com>
pkgname=libcsys
-pkgver=4.2.0
+pkgver=4.5.0
pkgrel=0
pkgdesc="Library for managing drive and getting system resource information in real time"
-arch="all !s390x !mips64" # polkit
+arch="all"
url="https://gitlab.com/cubocore"
license="GPL-3.0-or-later"
-depends="qt5-qtbase udisks2"
-makedepends="qt5-qtbase-dev cmake ninja"
-source="$pkgname-$pkgver.tar.gz::https://gitlab.com/cubocore/libcsys/-/archive/v$pkgver/libcsys-v$pkgver.tar.gz"
+depends="udisks2"
+makedepends="
+ qt5-qtbase-dev
+ cmake
+ samurai
+ "
+source="https://gitlab.com/cubocore/libcsys/-/archive/v$pkgver/libcsys-v$pkgver.tar.gz"
subpackages="$pkgname-dev"
builddir="$srcdir/$pkgname-v$pkgver"
-options="!check"
+options="!check" # No tests
build() {
- cmake ../$pkgname-v$pkgver \
- -GNinja \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
- ninja
+ cmake --build build
}
package() {
- DESTDIR="$pkgdir" ninja install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="ff9b98788f094db7d9574bf507049596a9a46e7532ede806b1e0369d77934e2d74d451f7d5ffd77bf2111c4a4fd8aea47ea86ef44a316bd2f211e955fb1cafaa libcsys-4.2.0.tar.gz"
+
+sha512sums="
+c3135df6cb48b02c079f209b65ef29ee206d11ed8215f6a6ec6a72c39fb3261b856fa55d001603778f19780b2e1014f06c938b9145ddeb78e2e8eed7e84dc0fc libcsys-v4.5.0.tar.gz
+"