aboutsummaryrefslogtreecommitdiffstats
path: root/community/libcsys/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libcsys/APKBUILD')
-rw-r--r--community/libcsys/APKBUILD31
1 files changed, 20 insertions, 11 deletions
diff --git a/community/libcsys/APKBUILD b/community/libcsys/APKBUILD
index b8a796f6760..4f66127fa43 100644
--- a/community/libcsys/APKBUILD
+++ b/community/libcsys/APKBUILD
@@ -1,26 +1,35 @@
# Contributor: rahmanshaber <rahmanshaber@yahoo.com>
# Maintainer: rahmanshaber <rahmanshaber@yahoo.com>
pkgname=libcsys
-pkgver=4.0.0
+pkgver=4.5.0
pkgrel=0
-pkgdesc="Library for managing a hard drive and getting system resource information in real-time."
-arch="all !s390x" # polkit
+pkgdesc="Library for managing drive and getting system resource information in real time"
+arch="all"
url="https://gitlab.com/cubocore"
license="GPL-3.0-or-later"
-depends="qt5-qtbase udisks2"
-makedepends="qt5-qtbase-dev"
-source="$pkgname-$pkgver.tar.gz::https://gitlab.com/cubocore/libcsys/-/archive/v$pkgver/libcsys-v$pkgver.tar.gz"
+depends="udisks2"
+makedepends="
+ qt5-qtbase-dev
+ cmake
+ samurai
+ "
+source="https://gitlab.com/cubocore/libcsys/-/archive/v$pkgver/libcsys-v$pkgver.tar.gz"
subpackages="$pkgname-dev"
builddir="$srcdir/$pkgname-v$pkgver"
-options="!check"
+options="!check" # No tests
build() {
- qmake-qt5
- make
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ cmake --build build
}
package() {
- INSTALL_ROOT="$pkgdir" make install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="1c3ce300f88a6825dcc73536d394abce35affda117388d34781c4dec5e4e9288743af2cbee1f7ad1f4b93fe6c1091f657191712aa59e78ea5b992800a215794a libcsys-4.0.0.tar.gz"
+sha512sums="
+c3135df6cb48b02c079f209b65ef29ee206d11ed8215f6a6ec6a72c39fb3261b856fa55d001603778f19780b2e1014f06c938b9145ddeb78e2e8eed7e84dc0fc libcsys-v4.5.0.tar.gz
+"