aboutsummaryrefslogtreecommitdiffstats
path: root/community/libcue/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libcue/APKBUILD')
-rw-r--r--community/libcue/APKBUILD31
1 files changed, 17 insertions, 14 deletions
diff --git a/community/libcue/APKBUILD b/community/libcue/APKBUILD
index f734d309b97..0a6325d0890 100644
--- a/community/libcue/APKBUILD
+++ b/community/libcue/APKBUILD
@@ -1,35 +1,38 @@
-# Contributor:
-# Maintainer:
+# Contributor:
+# Maintainer:
pkgname=libcue
-pkgver=2.2.1
+pkgver=2.3.0
pkgrel=0
pkgdesc="Library for parsing CUE sheet files"
url="https://github.com/lipnitsk/libcue"
-license="GPL-2.0"
+license="GPL-2.0-or-later"
arch="all"
-depends=
makedepends="cmake bison flex"
-install=
subpackages="$pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/lipnitsk/libcue/archive/v$pkgver.tar.gz"
+# secfixes:
+# 2.2.1-r2:
+# - CVE-2023-43641
+
build() {
- cd "$builddir"
- cmake \
+ cmake -B build . \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_SHARED_LIBS=true .
- make
+ -DBUILD_SHARED_LIBS=true
+ make -C build
}
check() {
- cd "$builddir"
+ cd build
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
+ make -C build DESTDIR="$pkgdir" install
}
-sha512sums="32e476cb09ed2cb2d64aaba1342fb91e77e448391b493a3a794a8d2a6723a0e6097a90b11c6ad82998cb7f270f4f18c2578d7b8575f6929c2a35502e09ebc964 libcue-2.2.1.tar.gz"
+sha512sums="
+fe2c39cc9794ac36c0706405e0432bab23228d343ba4e3395220d5b2a2ebf8b3c97e71d76a628f9144977c0dd56636f78d0c2d1f9f2b0d4068a837a258f035b6 libcue-2.3.0.tar.gz
+"