aboutsummaryrefslogtreecommitdiffstats
path: root/community/libdispatch/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libdispatch/APKBUILD')
-rw-r--r--community/libdispatch/APKBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/community/libdispatch/APKBUILD b/community/libdispatch/APKBUILD
index 8b0af057ea5..b3aad826635 100644
--- a/community/libdispatch/APKBUILD
+++ b/community/libdispatch/APKBUILD
@@ -1,13 +1,11 @@
# Contributor: Patrycja Rosa <alpine@ptrcnull.me>
# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
pkgname=libdispatch
-pkgver=5.6.1
-pkgrel=1
+pkgver=5.10
+pkgrel=0
pkgdesc="Comprehensive support for concurrent code execution on multicore hardware"
url="https://apple.github.io/swift-corelibs-libdispatch"
-# armhf: fatal error: error in backend: Cannot select: intrinsic %llvm.arm.clrex
-# riscv64: failing tests
-arch="all !armhf !riscv64"
+arch="all"
license="Apache-2.0"
depends_dev="$pkgname bsd-compat-headers"
makedepends="$depends_dev clang cmake samurai linux-headers"
@@ -35,7 +33,7 @@ build() {
check() {
ctest --output-on-failure -j $JOBS --test-dir build \
- -E dispatch_select # timeout
+ -E dispatch_select # fail
}
package() {
@@ -43,7 +41,7 @@ package() {
}
sha512sums="
-083a8ebdea87cc04f856db1833adcfca83b16568cff311123ccc6a835f73979ac1051f1733feacfa04155fcabc97f561738adf8e871468e808cf8048bea063b1 libdispatch-5.6.1.tar.gz
+95e697b95a1adab00f6634ffbb9a0214a05dac55df10e05f253813d513f3a198ff37eb136d0562dddfb8dc5a7cab8465a26d78f21f70fdfcda7614d6ff27d0b9 libdispatch-5.10.tar.gz
f446969a2ccd6368b8ae994712019271438b050659e6a600f1d542516981ff9879d65ba48c5c0c2664ed9961aa61edb6c8f5febe447bdeb0ad71b0d9fcd426df avoid-libkqueue.patch
28d74bee58c1db1ed6d865dfea7e6aca18435b5ccfa77bd172fed17bda93b8ed997b614c40b728e3412a3a61531f01ce1f2ce636dc08a21d1606a7099da7a90f remove-werror.patch
148da81026badd7999c2317dfcfe274e544562a5ef294253738add68d203e450d430a16f43eb6674c3b3b3f18a6b82799bce3f5aebcbe3f80ee460dbb38e4663 getprogname-musl.patch