aboutsummaryrefslogtreecommitdiffstats
path: root/community/libdmtx/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libdmtx/APKBUILD')
-rw-r--r--community/libdmtx/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/libdmtx/APKBUILD b/community/libdmtx/APKBUILD
new file mode 100644
index 00000000000..6d55429322b
--- /dev/null
+++ b/community/libdmtx/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=libdmtx
+pkgver=0.7.7
+pkgrel=1
+pkgdesc="A software for reading and writing Data Matrix 2D barcodes"
+url="https://github.com/dmtx"
+arch="all"
+license="BSD-2-Clause"
+makedepends="
+ autoconf
+ automake
+ libtool
+ "
+source="https://github.com/dmtx/libdmtx/archive/v$pkgver/libdmtx-$pkgver.tar.gz"
+subpackages="$pkgname-static $pkgname-dev $pkgname-libs $pkgname-doc"
+
+prepare() {
+ default_prepare
+
+ ./autogen.sh
+}
+
+build() {
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="
+802a697669afeb74da0cc3736fe7301fcc1653c1e3bebc343a8baf76e52226cc5509231519343267a92e22ebdfcc5b2825380339991340f054f0a6685d2ffcdc libdmtx-0.7.7.tar.gz
+"