aboutsummaryrefslogtreecommitdiffstats
path: root/community/libetonyek/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libetonyek/APKBUILD')
-rw-r--r--community/libetonyek/APKBUILD24
1 files changed, 15 insertions, 9 deletions
diff --git a/community/libetonyek/APKBUILD b/community/libetonyek/APKBUILD
index 6613252b248..de621b37f89 100644
--- a/community/libetonyek/APKBUILD
+++ b/community/libetonyek/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=libetonyek
-pkgver=0.1.9
-pkgrel=6
+pkgver=0.1.10
+pkgrel=9
pkgdesc="Import filter and tools for Apple Keynote presentations"
url="https://wiki.documentfoundation.org/DLP/Libraries/libetonyek"
arch="all"
@@ -10,8 +10,14 @@ license="MPL-2.0"
depends_dev="glm-dev boost-dev librevenge-dev libxml2-dev zlib-dev liblangtag-dev"
makedepends="$depends_dev gperf doxygen mdds-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
-source="https://dev-www.libreoffice.org/src/libetonyek/$pkgname-$pkgver.tar.xz
- missing-include.patch"
+source="https://dev-www.libreoffice.org/src/libetonyek/libetonyek-$pkgver.tar.xz"
+
+prepare() {
+ default_prepare
+
+ update_config_sub
+ update_config_guess
+}
build() {
./configure \
@@ -23,7 +29,7 @@ build() {
--infodir=/usr/share/info \
--localstatedir=/var \
--disable-werror \
- --with-mdds=1.5 \
+ --with-mdds=2.1 \
--disable-static
make
}
@@ -37,9 +43,9 @@ package() {
}
tools() {
- mkdir -p "$subpkgdir"/usr
- mv "$pkgdir"/usr/bin "$subpkgdir"/usr
+ amove usr/bin
}
-sha512sums="3f439b369d450bb1a4bdb3fe92023bda234b323cf676570f1738318c56867a97910f536280b9b164c3fdaa423a3ee669c935df75a5c700bc1530ea5b9a00391e libetonyek-0.1.9.tar.xz
-e089ed9892862f172f5d80f3301b4525b552ef54bf3022a175b8f570475de27a31cea9887635538d60eb4eb34c2ba8c025eb321408eeb0a2320d39e7b8135000 missing-include.patch"
+sha512sums="
+516a14fcb7b7b5898484a4263d593a036ac728b90144da9d1c22a5d0fdffc879839e19a7b390f99d924c390d433e64433fb08939b1e04ca24359315571c5772b libetonyek-0.1.10.tar.xz
+"