aboutsummaryrefslogtreecommitdiffstats
path: root/community/libevhtp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libevhtp/APKBUILD')
-rw-r--r--community/libevhtp/APKBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/community/libevhtp/APKBUILD b/community/libevhtp/APKBUILD
index cda8bbb0f52..622a7835f99 100644
--- a/community/libevhtp/APKBUILD
+++ b/community/libevhtp/APKBUILD
@@ -3,26 +3,28 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libevhtp
pkgver=1.2.18
-pkgrel=3
+pkgrel=6
pkgdesc="Flexible replacement for libevent's httpd API"
options="!check" # No testsuite
-url="https://github.com/criticalstack/libevhtp/"
+url="https://github.com/Yellow-Camper/libevhtp"
arch="all"
license="BSD-3-Clause"
-makedepends="cmake libevent-dev openssl1.1-compat-dev oniguruma-dev"
+makedepends="cmake libevent-dev openssl-dev>3 oniguruma-dev samurai"
subpackages="$pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/criticalstack/libevhtp/archive/$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Yellow-Camper/libevhtp/archive/$pkgver.tar.gz"
build() {
- cmake \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DBUILD_SHARED_LIBS=ON
- make
+ cmake --build build
}
package() {
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="e01d771a9358fcf912578f34acd235711a3231029b453781f2992cf51cea26aa3f1eb170d3a834f15d4f9b3f37235fb006853eeee509945e2c18e3a7fbb06ae4 libevhtp-1.2.18.tar.gz"
+sha512sums="
+e01d771a9358fcf912578f34acd235711a3231029b453781f2992cf51cea26aa3f1eb170d3a834f15d4f9b3f37235fb006853eeee509945e2c18e3a7fbb06ae4 libevhtp-1.2.18.tar.gz
+"