aboutsummaryrefslogtreecommitdiffstats
path: root/community/libglacierapp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libglacierapp/APKBUILD')
-rw-r--r--community/libglacierapp/APKBUILD35
1 files changed, 0 insertions, 35 deletions
diff --git a/community/libglacierapp/APKBUILD b/community/libglacierapp/APKBUILD
deleted file mode 100644
index ad583e0c863..00000000000
--- a/community/libglacierapp/APKBUILD
+++ /dev/null
@@ -1,35 +0,0 @@
-# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
-pkgname=libglacierapp
-pkgver=0.8.1
-pkgrel=1
-pkgdesc="Glacier applications wrapper library"
-url="https://github.com/nemomobile-ux/libglacierapp"
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
-license="LGPL-2.0-or-later"
-depends_dev="
- qt5-qtbase-dev
- qt5-qtdeclarative-dev
- mlite-dev
- samurai
- "
-makedepends="$depends_dev cmake"
-subpackages="$pkgname-dev"
-source="https://github.com/nemomobile-ux/libglacierapp/archive/$pkgver/libglacierapp-$pkgver.tar.gz"
-options="!check" # No tests
-
-build() {
- cmake -B build -G Ninja \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
- cmake --build build
-}
-
-package() {
- DESTDIR="$pkgdir" cmake --install build
-}
-
-sha512sums="
-7cba1be446c3dda0523637ad31dca75fdaae27949f05c1760ad1f262cb1490bdae02e35eb0298b5c1d041ada88b5018509af2a17a85e017ba979dd379c90c01a libglacierapp-0.8.1.tar.gz
-"