aboutsummaryrefslogtreecommitdiffstats
path: root/community/libglibutil/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libglibutil/APKBUILD')
-rw-r--r--community/libglibutil/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/libglibutil/APKBUILD b/community/libglibutil/APKBUILD
new file mode 100644
index 00000000000..2a69597aa3a
--- /dev/null
+++ b/community/libglibutil/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Danct12 <danct12@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=libglibutil
+pkgver=1.0.77
+pkgrel=0
+pkgdesc="Library of glib utilities"
+url="https://github.com/sailfishos/libglibutil"
+arch="all"
+license="BSD-3-Clause"
+makedepends="glib-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://github.com/sailfishos/libglibutil/archive/$pkgver/libglibutil-$pkgver.tar.gz"
+
+build() {
+ make KEEP_SYMBOLS=1 release pkgconfig
+}
+
+check() {
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install-dev
+ install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+sha512sums="
+3532a484e7c1ddd9b3ec8cb54a9c6d2fb6db0a413841c90139583a7ec9b873af1c4fc276a3f786042804f0f2159418ac213350dae7a1ed5a23cc31cb47e2dcd8 libglibutil-1.0.77.tar.gz
+"