aboutsummaryrefslogtreecommitdiffstats
path: root/community/libglibutil/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libglibutil/APKBUILD')
-rw-r--r--community/libglibutil/APKBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/community/libglibutil/APKBUILD b/community/libglibutil/APKBUILD
index 2b21d376c62..2a69597aa3a 100644
--- a/community/libglibutil/APKBUILD
+++ b/community/libglibutil/APKBUILD
@@ -1,26 +1,29 @@
# Contributor: Danct12 <danct12@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=libglibutil
-pkgver=1.0.55
+pkgver=1.0.77
pkgrel=0
pkgdesc="Library of glib utilities"
-url="https://git.sailfishos.org/mer-core/libglibutil"
+url="https://github.com/sailfishos/libglibutil"
arch="all"
license="BSD-3-Clause"
makedepends="glib-dev"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://git.sailfishos.org/mer-core/libglibutil/-/archive/$pkgver/libglibutil-$pkgver.tar.gz"
-options="!check" # test_log.c: error: assignment of read-only variable 'stdout'
+source="https://github.com/sailfishos/libglibutil/archive/$pkgver/libglibutil-$pkgver.tar.gz"
build() {
make KEEP_SYMBOLS=1 release pkgconfig
}
+check() {
+ make test
+}
+
package() {
make DESTDIR="$pkgdir" install-dev
install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
sha512sums="
-48ed4bff04831516f12c721aab04b161cffa1f4f9a7ff0e8d776f71319cee4a9becc707609ee1d8ab2137e14dcc019248bb02c78de7a0099c6d69f9b31af2b31 libglibutil-1.0.55.tar.gz
+3532a484e7c1ddd9b3ec8cb54a9c6d2fb6db0a413841c90139583a7ec9b873af1c4fc276a3f786042804f0f2159418ac213350dae7a1ed5a23cc31cb47e2dcd8 libglibutil-1.0.77.tar.gz
"