aboutsummaryrefslogtreecommitdiffstats
path: root/community/libglibutil/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libglibutil/APKBUILD')
-rw-r--r--community/libglibutil/APKBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/community/libglibutil/APKBUILD b/community/libglibutil/APKBUILD
index 69faa8057f9..2a69597aa3a 100644
--- a/community/libglibutil/APKBUILD
+++ b/community/libglibutil/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Danct12 <danct12@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=libglibutil
-pkgver=1.0.61
+pkgver=1.0.77
pkgrel=0
pkgdesc="Library of glib utilities"
url="https://github.com/sailfishos/libglibutil"
@@ -10,17 +10,20 @@ license="BSD-3-Clause"
makedepends="glib-dev"
subpackages="$pkgname-dev $pkgname-doc"
source="https://github.com/sailfishos/libglibutil/archive/$pkgver/libglibutil-$pkgver.tar.gz"
-options="!check" # test_log.c: error: assignment of read-only variable 'stdout'
build() {
make KEEP_SYMBOLS=1 release pkgconfig
}
+check() {
+ make test
+}
+
package() {
make DESTDIR="$pkgdir" install-dev
install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
sha512sums="
-ce5c2dafd5d8b37c84b3fa3ff413565702241c15d205325dfb162590de10953aacc17238918ac3f85e62a336a482c01232cfdc11ee8acae6577c0268d231a1ca libglibutil-1.0.61.tar.gz
+3532a484e7c1ddd9b3ec8cb54a9c6d2fb6db0a413841c90139583a7ec9b873af1c4fc276a3f786042804f0f2159418ac213350dae7a1ed5a23cc31cb47e2dcd8 libglibutil-1.0.77.tar.gz
"