aboutsummaryrefslogtreecommitdiffstats
path: root/community/libgnome-games-support/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libgnome-games-support/APKBUILD')
-rw-r--r--community/libgnome-games-support/APKBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/community/libgnome-games-support/APKBUILD b/community/libgnome-games-support/APKBUILD
index 1433f2cbaa7..c1827267ca0 100644
--- a/community/libgnome-games-support/APKBUILD
+++ b/community/libgnome-games-support/APKBUILD
@@ -1,27 +1,32 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libgnome-games-support
pkgver=1.8.1
-pkgrel=1
+pkgrel=2
arch="all"
url="https://gitlab.gnome.org/GNOME/libgnome-games-support"
pkgdesc="Code shared between GNOME games"
license="LGPL-3.0-or-later"
makedepends="meson ninja vala libgee-dev gtk+3.0-dev"
-source="https://download.gnome.org/sources/libgnome-games-support/${pkgver%.*}/libgnome-games-support-$pkgver.tar.xz"
+source="https://download.gnome.org/sources/libgnome-games-support/${pkgver%.*}/libgnome-games-support-$pkgver.tar.xz
+ vala-0.56.patch
+ "
subpackages="$pkgname-dev $pkgname-lang"
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="ed5ba94db9ab3d6193e7bb2d0956e20c42577b9fdba4d1d31acb252c43d248cc9b478c807b5f9489dfc88d6757bf95206405d0adf4fb68aa50b8f9d1b6ec59bf libgnome-games-support-1.8.1.tar.xz"
+sha512sums="
+ed5ba94db9ab3d6193e7bb2d0956e20c42577b9fdba4d1d31acb252c43d248cc9b478c807b5f9489dfc88d6757bf95206405d0adf4fb68aa50b8f9d1b6ec59bf libgnome-games-support-1.8.1.tar.xz
+7a18c75fe7c17850b74b3595dea2ace4e2bcf1ce5914819490834e4e0f2cf96f5b59a2371f56124ef8d10be4d2848242659cccd15df0d07b7c0a4885b95374cc vala-0.56.patch
+"