aboutsummaryrefslogtreecommitdiffstats
path: root/community/libgnomekbd/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libgnomekbd/APKBUILD')
-rw-r--r--community/libgnomekbd/APKBUILD46
1 files changed, 27 insertions, 19 deletions
diff --git a/community/libgnomekbd/APKBUILD b/community/libgnomekbd/APKBUILD
index 5de27200adf..845711e8f73 100644
--- a/community/libgnomekbd/APKBUILD
+++ b/community/libgnomekbd/APKBUILD
@@ -1,38 +1,46 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer:
pkgname=libgnomekbd
-pkgver=3.26.1
-pkgrel=1
+pkgver=3.28.1
+pkgrel=3
pkgdesc="GNOME keyboard library"
url="https://www.gnome.org/"
arch="all"
license="GPL-2.0-or-later"
depends="desktop-file-utils"
-depends_dev="gtk+3.0-dev libxklavier-dev libxml2-dev gobject-introspection-dev
- libxcursor-dev libxcomposite-dev libxi-dev libxau-dev libxdmcp-dev libxext-dev
- libxcb-dev"
-makedepends="$depends_dev intltool"
+depends_dev="
+ gobject-introspection-dev
+ gtk+3.0-dev
+ libxau-dev
+ libxcb-dev
+ libxcomposite-dev
+ libxcursor-dev
+ libxdmcp-dev
+ libxext-dev
+ libxi-dev
+ libxklavier-dev
+ libxml2-dev
+ "
+makedepends="$depends_dev meson"
subpackages="$pkgname-dev $pkgname-lang"
-source="https://download.gnome.org/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.xz"
+source="https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
build() {
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --disable-static \
- --enable-tests \
- --enable-introspection
- make
+ abuild-meson \
+ -Db_lto=true \
+ . output
+
+ meson compile -C output
}
check() {
- make check
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="8e83522f4d96001f9635278a001e0208d6d37e74b19a8c1702ec6de651036ad37a03385e66adbd3bae01d845a9a6181bb76f45bffec31eac98d600b49ab4360c libgnomekbd-3.26.1.tar.xz"
+sha512sums="
+ffcabfe19289057dd3d7489170093ff1614c3344103ba8ebc6c69f5668d01fea652b7be6c7d5c66291df3a319f975df5cf5167168cd0f60cede022b76bb57cb5 libgnomekbd-3.28.1.tar.xz
+"