aboutsummaryrefslogtreecommitdiffstats
path: root/community/libgweather/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libgweather/APKBUILD')
-rw-r--r--community/libgweather/APKBUILD37
1 files changed, 0 insertions, 37 deletions
diff --git a/community/libgweather/APKBUILD b/community/libgweather/APKBUILD
deleted file mode 100644
index ec6ab7e0efe..00000000000
--- a/community/libgweather/APKBUILD
+++ /dev/null
@@ -1,37 +0,0 @@
-# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
-pkgname=libgweather
-pkgver=40.0
-pkgrel=0
-pkgdesc="GNOME weather library"
-url="https://wiki.gnome.org/Projects/LibGWeather"
-arch="all"
-license="LGPL-2.1-or-later"
-depends="tzdata gsettings-desktop-schemas"
-makedepends="gtk+3.0-dev libsoup-dev libxml2-dev vala
- glib-dev geocode-glib-dev gobject-introspection-dev
- libxml2-utils gtk-doc glade-dev meson ninja
- py3-gobject3"
-options="!check" # Fail due to musl locale support
-subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="https://download.gnome.org/sources/libgweather/${pkgver%.*}/libgweather-$pkgver.tar.xz"
-
-build() {
- abuild-meson \
- -Dgtk_doc=true \
- -Denable_vala=true \
- . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
-}
-
-check() {
- meson test --no-rebuild -v -C output
-}
-
-package() {
- DESTDIR="$pkgdir" meson install --no-rebuild -C output
-}
-
-
-sha512sums="72e295246bf03550039a70bd4bf5b8f06357a6b70e04308c197fba309e406d410a97d128d849d97a29a6a114faa1ef5452e6632870b7ea45223a0c305c228cc1 libgweather-40.0.tar.xz"