aboutsummaryrefslogtreecommitdiffstats
path: root/community/libgweather4/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libgweather4/APKBUILD')
-rw-r--r--community/libgweather4/APKBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/community/libgweather4/APKBUILD b/community/libgweather4/APKBUILD
index fd282363505..8fb51364d32 100644
--- a/community/libgweather4/APKBUILD
+++ b/community/libgweather4/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Newbyte <newbie13xd@gmail.com>
pkgname=libgweather4
-pkgver=4.0.0
+pkgver=4.4.2
pkgrel=0
pkgdesc="GNOME weather library"
url="https://wiki.gnome.org/Projects/LibGWeather"
@@ -10,15 +10,16 @@ arch="all"
license="LGPL-2.1-or-later"
depends="tzdata gsettings-desktop-schemas"
makedepends="
- geocode-glib-dev
+ font-cantarell
+ geocode-glib-dev>=3.26.4-r1
gi-docgen
glib-dev
gobject-introspection-dev
- libsoup-dev
+ json-glib-dev
+ libsoup3-dev
libxml2-dev
meson
py3-gobject3
- ttf-cantarell
vala
"
options="!check" # Fail due to musl locale support
@@ -28,21 +29,21 @@ builddir="$srcdir/libgweather-$pkgver"
build() {
abuild-meson \
+ -Db_lto=true \
-Dgtk_doc=true \
-Denable_vala=true \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-
sha512sums="
-1441b8996a53b277e9453d3fcf32448800c963f40c32542f9055362bc3188dcf2e706466133d53b3f1b6343dc97b15cf5eabe16b950e7c9451cb79eeef87a9c3 libgweather-4.0.0.tar.xz
+66012af9bc50dfbb8cdb3d8b1ad7c72b5e8e012d8bbaa5a8d7a841f4bd5b2ebe0a490cc7ea256ea5e1d218f328da8826fb2345aa848fd961da271e64cdf330ad libgweather-4.4.2.tar.xz
"