aboutsummaryrefslogtreecommitdiffstats
path: root/community/libgweather4/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libgweather4/APKBUILD')
-rw-r--r--community/libgweather4/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/community/libgweather4/APKBUILD b/community/libgweather4/APKBUILD
new file mode 100644
index 00000000000..8fb51364d32
--- /dev/null
+++ b/community/libgweather4/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Newbyte <newbie13xd@gmail.com>
+pkgname=libgweather4
+pkgver=4.4.2
+pkgrel=0
+pkgdesc="GNOME weather library"
+url="https://wiki.gnome.org/Projects/LibGWeather"
+arch="all"
+license="LGPL-2.1-or-later"
+depends="tzdata gsettings-desktop-schemas"
+makedepends="
+ font-cantarell
+ geocode-glib-dev>=3.26.4-r1
+ gi-docgen
+ glib-dev
+ gobject-introspection-dev
+ json-glib-dev
+ libsoup3-dev
+ libxml2-dev
+ meson
+ py3-gobject3
+ vala
+ "
+options="!check" # Fail due to musl locale support
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="https://download.gnome.org/sources/libgweather/${pkgver%.*}/libgweather-$pkgver.tar.xz"
+builddir="$srcdir/libgweather-$pkgver"
+
+build() {
+ abuild-meson \
+ -Db_lto=true \
+ -Dgtk_doc=true \
+ -Denable_vala=true \
+ . output
+ meson compile -C output
+}
+
+check() {
+ meson test --no-rebuild --print-errorlogs -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+}
+
+sha512sums="
+66012af9bc50dfbb8cdb3d8b1ad7c72b5e8e012d8bbaa5a8d7a841f4bd5b2ebe0a490cc7ea256ea5e1d218f328da8826fb2345aa848fd961da271e64cdf330ad libgweather-4.4.2.tar.xz
+"