aboutsummaryrefslogtreecommitdiffstats
path: root/community/libhandy/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libhandy/APKBUILD')
-rw-r--r--community/libhandy/APKBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/community/libhandy/APKBUILD b/community/libhandy/APKBUILD
index edf7637f29b..18219918404 100644
--- a/community/libhandy/APKBUILD
+++ b/community/libhandy/APKBUILD
@@ -1,11 +1,11 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libhandy
pkgver=0.0.13
-pkgrel=4
+pkgrel=6
pkgdesc="Library full of GTK+ widgets for mobile phones"
url="https://source.puri.sm/Librem5/libhandy"
-arch="all !s390x !mips !mips64" # Limited by 'ibus'
+arch="all"
license="LGPL-2.0-or-later"
makedepends="meson glib-dev gtk+3.0-dev vala py3-setuptools gobject-introspection-dev"
checkdepends="xvfb-run ibus"
@@ -19,11 +19,11 @@ build() {
abuild-meson \
-Dexamples=true \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- xvfb-run meson test --no-rebuild -v -C output
+ xvfb-run meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -37,5 +37,7 @@ dev() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr
}
-sha512sums="b9eaef775a93c200aa3f526b627827ed4530ff2a4c826ab24abdbd944075c0939232bd2c3388b8b8e34c6729cb11017a7af2bd3ff9eec78fbdc7e7dd9f11d24b libhandy-v0.0.13.tar.gz
-e67a51b2985d27f1ed259773060e7df1430f7529f6cef69b1a240f97bfdccb73bd97303b96e209daa2ff7d31094f290986a663d4c7919b4799ec333b8e06a83f skip-test.patch"
+sha512sums="
+b9eaef775a93c200aa3f526b627827ed4530ff2a4c826ab24abdbd944075c0939232bd2c3388b8b8e34c6729cb11017a7af2bd3ff9eec78fbdc7e7dd9f11d24b libhandy-v0.0.13.tar.gz
+699b17da5aa1a0bff9bbaf962d84edcc80fba21130cf9f12cff004d84c6cd182a44c462acebf9ce4cddf26da61484f85985a94eb7812fe2d3639625182f41bb4 skip-test.patch
+"