aboutsummaryrefslogtreecommitdiffstats
path: root/community/libhandy1/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libhandy1/APKBUILD')
-rw-r--r--community/libhandy1/APKBUILD45
1 files changed, 22 insertions, 23 deletions
diff --git a/community/libhandy1/APKBUILD b/community/libhandy1/APKBUILD
index 3a5a7fd69e7..a41d467fc01 100644
--- a/community/libhandy1/APKBUILD
+++ b/community/libhandy1/APKBUILD
@@ -1,46 +1,45 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libhandy1
-pkgver=1.6.1
+pkgver=1.8.3
pkgrel=0
pkgdesc="Library full of GTK+ widgets for mobile phones"
url="https://gitlab.gnome.org/GNOME/libhandy"
-arch="all !s390x !riscv64" # blocked by rust -> adwaita-icon-theme
+arch="all"
license="LGPL-2.0-or-later"
-makedepends="meson glib-dev gtk+3.0-dev vala py3-setuptools gobject-introspection-dev
- glade-dev"
-checkdepends="xvfb-run ibus adwaita-icon-theme ttf-cantarell"
-subpackages="$pkgname-dbg $pkgname-dev $pkgname-lang"
-source="https://download.gnome.org/sources/libhandy/${pkgver%.*}/libhandy-$pkgver.tar.xz
+makedepends="
+ glib-dev
+ gobject-introspection-dev
+ gtk+3.0-dev
+ meson
+ py3-setuptools
+ vala
+ "
+checkdepends="
+ adwaita-icon-theme
+ ibus
+ xvfb-run
"
+subpackages="$pkgname-dbg $pkgname-dev $pkgname-lang"
+source="https://download.gnome.org/sources/libhandy/${pkgver%.*}/libhandy-$pkgver.tar.xz"
builddir="$srcdir/libhandy-$pkgver"
-if [ "$CARCH" = "armhf" ]; then
- options="!check"; # tests fail on armhf
-fi
-
build() {
abuild-meson \
- -Dexamples=true \
+ -Db_lto=true \
+ -Dexamples=false \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- xvfb-run meson test --timeout-multiplier=2 --no-rebuild -v -C output
+ xvfb-run -a meson test -t 3 --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-dev() {
- default_dev
-
- mkdir -p "$subpkgdir"/usr
- mv "$pkgdir"/usr/bin "$subpkgdir"/usr
-}
-
sha512sums="
-1fddf72d7e6d97f12c879a512baeef80e32be4108640b2ff64c5b7dec68d8e2da8f9a2da3c1cb6cde8c2e672f4225e7db698f794641264e64ee9af3c68dbfbb3 libhandy-1.6.1.tar.xz
+1e0ae363d2a4993c9667243715256b27cb0ecb898fa8f4ea1a914fbeb36c0a9c26447f8f13f92f5a855e45ada49f732adeb30b88d81f3ee5f984bca48db3ae65 libhandy-1.8.3.tar.xz
"