aboutsummaryrefslogtreecommitdiffstats
path: root/community/libimobiledevice/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libimobiledevice/APKBUILD')
-rw-r--r--community/libimobiledevice/APKBUILD36
1 files changed, 24 insertions, 12 deletions
diff --git a/community/libimobiledevice/APKBUILD b/community/libimobiledevice/APKBUILD
index 80f80852505..03ad1374121 100644
--- a/community/libimobiledevice/APKBUILD
+++ b/community/libimobiledevice/APKBUILD
@@ -1,19 +1,24 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=libimobiledevice
-pkgver=1.2.0
-pkgrel=3
-pkgdesc="Library that talks the protocols to support iPhone and iPod Touch devices on Linux"
-url="http://libimobiledevice.org/"
+pkgver=1.3.0
+pkgrel=8
+pkgdesc="Library that talks iPhone and iPod Touch protocols on Linux"
+url="https://libimobiledevice.org"
arch="all"
license="LGPL-2.1-or-later"
-makedepends="openssl-dev libusbmuxd-dev libplist-dev"
-subpackages="$pkgname-dev $pkgname-doc"
-source="http://libimobiledevice.org/downloads/$pkgname-$pkgver.tar.bz2
- 13bf235cac2201747de11652cf14fe2714ca0718.patch
- 02a0e03e24bc96bba2e5ea2438c30baf803fd137.patch"
+makedepends="openssl-dev>3 libusbmuxd-dev libplist-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-progs"
+source="https://github.com/libimobiledevice/libimobiledevice/releases/download/$pkgver/libimobiledevice-$pkgver.tar.bz2
+ libplist-2.3.0.patch
+ "
+prepare() {
+ default_prepare
+ update_config_guess
+}
build() {
+ export CFLAGS="$CFLAGS -Wno-error=int-conversion"
./configure \
--prefix=/usr \
--disable-static \
@@ -29,6 +34,13 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="0de5f768aeb5d62445892855d84ceaff776f6667733c351ed6c34bf9d500802762d1a06e5efdf57f33cafc9ee788041cd9b6748fb9bad6c2e4ae2f9b9aa93589 libimobiledevice-1.2.0.tar.bz2
-bd2d16c033796573baab41deac4b84850328103e9218e0afee500a2ae83aa4b97a9d2e5d3cf66ad8c9f120dc2fbf434b374994b2b3438c6c595ffbd39bf50da3 13bf235cac2201747de11652cf14fe2714ca0718.patch
-50668350cc0540cab56c1f7ece2c7e48f49113c01cdfb5c2e0c8d3b8b4593edd4dceb170df97bb7f077d6af7ec7234f525d0fbcb8b9f0f03d5c36a9a9751f600 02a0e03e24bc96bba2e5ea2438c30baf803fd137.patch"
+progs() {
+ pkgdesc="Tools that talks iPhone and iPod Touch devices' protocols on Linux"
+ depends=""
+ amove usr/bin
+}
+
+sha512sums="
+7b22040552a6561729c79c0846f571b0e608abb7c297567d2ecfdd1718ce86df08a5e34ba51f209bdee96a1917da15e7ba3aaef1d289a951d1d3470b1f89e6a8 libimobiledevice-1.3.0.tar.bz2
+f6523d38394a33712bd24a3725a9cb494e8e20e20ccfd396d25cee6001372dcb6f4b0a1231b1c475441d5c5cf5e89305e141f025621631331591a3da0d7ac99d libplist-2.3.0.patch
+"