aboutsummaryrefslogtreecommitdiffstats
path: root/community/libimobiledevice/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libimobiledevice/APKBUILD')
-rw-r--r--community/libimobiledevice/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/libimobiledevice/APKBUILD b/community/libimobiledevice/APKBUILD
new file mode 100644
index 00000000000..80f80852505
--- /dev/null
+++ b/community/libimobiledevice/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=libimobiledevice
+pkgver=1.2.0
+pkgrel=3
+pkgdesc="Library that talks the protocols to support iPhone and iPod Touch devices on Linux"
+url="http://libimobiledevice.org/"
+arch="all"
+license="LGPL-2.1-or-later"
+makedepends="openssl-dev libusbmuxd-dev libplist-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://libimobiledevice.org/downloads/$pkgname-$pkgver.tar.bz2
+ 13bf235cac2201747de11652cf14fe2714ca0718.patch
+ 02a0e03e24bc96bba2e5ea2438c30baf803fd137.patch"
+
+build() {
+ ./configure \
+ --prefix=/usr \
+ --disable-static \
+ --without-cython
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="0de5f768aeb5d62445892855d84ceaff776f6667733c351ed6c34bf9d500802762d1a06e5efdf57f33cafc9ee788041cd9b6748fb9bad6c2e4ae2f9b9aa93589 libimobiledevice-1.2.0.tar.bz2
+bd2d16c033796573baab41deac4b84850328103e9218e0afee500a2ae83aa4b97a9d2e5d3cf66ad8c9f120dc2fbf434b374994b2b3438c6c595ffbd39bf50da3 13bf235cac2201747de11652cf14fe2714ca0718.patch
+50668350cc0540cab56c1f7ece2c7e48f49113c01cdfb5c2e0c8d3b8b4593edd4dceb170df97bb7f077d6af7ec7234f525d0fbcb8b9f0f03d5c36a9a9751f600 02a0e03e24bc96bba2e5ea2438c30baf803fd137.patch"