aboutsummaryrefslogtreecommitdiffstats
path: root/community/libinput/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libinput/APKBUILD')
-rw-r--r--community/libinput/APKBUILD59
1 files changed, 45 insertions, 14 deletions
diff --git a/community/libinput/APKBUILD b/community/libinput/APKBUILD
index 2226af4c552..89e4df74b10 100644
--- a/community/libinput/APKBUILD
+++ b/community/libinput/APKBUILD
@@ -1,50 +1,81 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
-# Maintainer: Daniel Sabogal <dsabogalcc@gmail.com>
+# Contributor: Daniel Sabogal <dsabogalcc@gmail.com>
+# Maintainer: Simon Zeni <simon@bl4ckb0ne.ca>
pkgname=libinput
-pkgver=1.19.3
+pkgver=1.25.0
pkgrel=0
pkgdesc="Library for handling input devices"
url="https://www.freedesktop.org/wiki/Software/libinput"
arch="all"
license="MIT"
-_depends_tools="python3 py3-libevdev py3-udev py3-yaml"
-makedepends="eudev-dev gtk+3.0-dev libevdev-dev meson mtdev-dev $_depends_tools"
-checkdepends="diffutils bash"
+_depends_tools="
+ py3-libevdev
+ py3-udev
+ py3-yaml
+ python3
+ "
+depends_dev="
+ eudev-dev
+ "
+makedepends="
+ $_depends_tools
+ $depends_dev
+ gtk+3.0-dev
+ libevdev-dev
+ meson
+ mtdev-dev
+ "
+checkdepends="
+ bash
+ check-dev
+ py3-pytest
+ "
subpackages="
$pkgname-dev
$pkgname-doc
$pkgname-libs
+ $pkgname-udev
$pkgname-debug-gui:_debug_gui
$pkgname-tools
$pkgname-zsh-completion
"
install="$pkgname.post-upgrade"
-source="https://freedesktop.org/software/libinput/libinput-$pkgver.tar.xz"
+source="https://gitlab.freedesktop.org/libinput/libinput/-/archive/$pkgver/libinput-$pkgver.tar.gz"
+
+# secfixes:
+# 1.20.1-r0:
+# - CVE-2022-1215
build() {
abuild-meson \
+ -Db_lto=true \
-Ddocumentation=false \
-Dlibwacom=false \
-Ddebug-gui=true \
- -Dtests=false builddir/
- meson compile ${JOBS:+-j ${JOBS}} -C builddir/
+ -Dtests="$(want_check && echo true || echo false)" \
+ . output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C builddir
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
- DESTDIR="$pkgdir" meson install --no-rebuild -C builddir
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
libs() {
default_libs
- mv "$pkgdir"/usr/lib/udev "$subpkgdir"/usr/lib
- mkdir -p "$subpkgdir"/usr/share/
- mv "$pkgdir"/usr/share/libinput "$subpkgdir"/usr/share
+ amove usr/share/libinput
+}
+
+udev() {
+ install_if="$pkgname-libs=$pkgver-r$pkgrel eudev"
+
+ amove usr/lib/udev
}
tools() {
@@ -68,5 +99,5 @@ _debug_gui() {
}
sha512sums="
-f4b776d0da78c687ba21b430a04941ac6b43f68970c82ec9f7360358fdea5ed6a873948ce66a25bcdd64d4b95fa4bf705cc24dbc25c7c0f5fd2d0efbd763f298 libinput-1.19.3.tar.xz
+17c668d04e3ff7d3e99519f7e7fe37377bd25e90ff36acc8c3f06f6de31265514780a0823b6fbd5712272a6b6f759bf768cb35b4f68c29828c1964899e9ee752 libinput-1.25.0.tar.gz
"