aboutsummaryrefslogtreecommitdiffstats
path: root/community/libinputsynth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libinputsynth/APKBUILD')
-rw-r--r--community/libinputsynth/APKBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/community/libinputsynth/APKBUILD b/community/libinputsynth/APKBUILD
index 56b979b98f1..9c717f19e12 100644
--- a/community/libinputsynth/APKBUILD
+++ b/community/libinputsynth/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=libinputsynth
-pkgver=0.15.0
+pkgver=0.16.0
pkgrel=0
pkgdesc="Synthesize keyboard and mouse input on X11 and Wayland with various backends"
url="https://gitlab.freedesktop.org/xrdesktop/xrdesktop"
@@ -16,21 +16,23 @@ makedepends="$depends_dev
meson
"
source="https://gitlab.freedesktop.org/xrdesktop/libinputsynth/-/archive/$pkgver/libinputsynth-$pkgver.tar.gz"
-subpackages="$pkgname-dev"
+subpackages="$pkgname-dev $pkgname-doc"
build() {
abuild-meson \
-Dapi_doc=true \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output --no-suite post-install
+ meson test --no-rebuild --print-errorlogs -C output --no-suite post-install
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="bd4054b05a297f28678bd066f2a7eb62bce0b39ffe0e3bbe6d0ce1323f80b4290ee951c8f9c1006ca77f3ad15282ed6e2c4a960f590487b066202c5738398e24 libinputsynth-0.15.0.tar.gz"
+sha512sums="
+06568d8217823d479bee301954516b64968c188645ea073dc30b5152a13e922bca43474e66c55edd02ef0c7013a7cad5e2e16e4169d1fa0faacf54b0467ec764 libinputsynth-0.16.0.tar.gz
+"