aboutsummaryrefslogtreecommitdiffstats
path: root/community/libkcddb/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libkcddb/APKBUILD')
-rw-r--r--community/libkcddb/APKBUILD32
1 files changed, 21 insertions, 11 deletions
diff --git a/community/libkcddb/APKBUILD b/community/libkcddb/APKBUILD
index 56bf641b3fc..7a9a31a96d9 100644
--- a/community/libkcddb/APKBUILD
+++ b/community/libkcddb/APKBUILD
@@ -1,16 +1,19 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=libkcddb
-pkgver=22.04.3
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://www.kde.org/applications/multimedia/"
pkgdesc="KDE CDDB library"
license="LGPL-2.0-or-later AND GPL-2.0-or-later"
makedepends="
extra-cmake-modules
+ kcmutils-dev
kcodecs-dev
kconfig-dev
kdoctools-dev
@@ -18,15 +21,21 @@ makedepends="
kio-dev
kwidgetsaddons-dev
libmusicbrainz-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/libkcddb-$pkgver.tar.xz"
+checkdepends="
+ dbus
+ xvfb-run
+ "
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/multimedia/libkcddb.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/libkcddb-$pkgver.tar.xz"
options="net" # Required for tests
build() {
cmake -B build -G Ninja \
+ -DBUILD_WITH_QT6=ON \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
@@ -35,10 +44,11 @@ build() {
}
check() {
- cd build
- # musicbrainztest-severaldiscs, asynccddblookuptest and synccddblookuptest are broken
- # asynchttplookuptest fails to setup dbus
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E "(musicbrainztest-severaldiscs|asynchttplookuptest|asynccddblookuptest|synccddblookuptest)"
+ # musicbrainztest-severaldiscs fails due to utf16/8 (?)
+ # synchttplookuptest hangs
+ # asyncmusicbrainztest http request
+ dbus-run-session -- xvfb-run -a ctest --test-dir build --output-on-failure \
+ -E "(asyncmusicbrainztest|synchttplookuptest|musicbrainztest-severaldiscs|synccddblookuptest|asynchttpsubmittest|synchttpsubmittest|sitestest|utf8test)"
}
package() {
@@ -46,5 +56,5 @@ package() {
}
sha512sums="
-4bd1e4f39ef8adb7957e9f186be55685b176057e3f80cd244586d5a65ddd507df8c6cd417ff98d9a6c898ff8604731641647e5a739d76b2049d031b91ba62fb6 libkcddb-22.04.3.tar.xz
+63846960a2817fb4f296818f3d16139bca4f2fc9f38d16417cd395497f6d0b6444acb867108077bf5713fa007c92e9f28d267d23794b490896ec23d6f32f4a79 libkcddb-24.02.2.tar.xz
"