aboutsummaryrefslogtreecommitdiffstats
path: root/community/libkcddb/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libkcddb/APKBUILD')
-rw-r--r--community/libkcddb/APKBUILD37
1 files changed, 24 insertions, 13 deletions
diff --git a/community/libkcddb/APKBUILD b/community/libkcddb/APKBUILD
index fe2c6c335c7..7a9a31a96d9 100644
--- a/community/libkcddb/APKBUILD
+++ b/community/libkcddb/APKBUILD
@@ -1,16 +1,19 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=libkcddb
-pkgver=21.12.1
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://www.kde.org/applications/multimedia/"
pkgdesc="KDE CDDB library"
license="LGPL-2.0-or-later AND GPL-2.0-or-later"
makedepends="
extra-cmake-modules
+ kcmutils-dev
kcodecs-dev
kconfig-dev
kdoctools-dev
@@ -18,15 +21,22 @@ makedepends="
kio-dev
kwidgetsaddons-dev
libmusicbrainz-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
+ "
+checkdepends="
+ dbus
+ xvfb-run
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/libkcddb-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/multimedia/libkcddb.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/libkcddb-$pkgver.tar.xz"
options="net" # Required for tests
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DBUILD_WITH_QT6=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_TESTING=ON
@@ -34,10 +44,11 @@ build() {
}
check() {
- cd build
- # musicbrainztest-severaldiscs, asynccddblookuptest and synccddblookuptest are broken
- # asynchttplookuptest fails to setup dbus
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E "(musicbrainztest-severaldiscs|asynchttplookuptest|asynccddblookuptest|synccddblookuptest)"
+ # musicbrainztest-severaldiscs fails due to utf16/8 (?)
+ # synchttplookuptest hangs
+ # asyncmusicbrainztest http request
+ dbus-run-session -- xvfb-run -a ctest --test-dir build --output-on-failure \
+ -E "(asyncmusicbrainztest|synchttplookuptest|musicbrainztest-severaldiscs|synccddblookuptest|asynchttpsubmittest|synchttpsubmittest|sitestest|utf8test)"
}
package() {
@@ -45,5 +56,5 @@ package() {
}
sha512sums="
-313ba00ce1f398736eb98f0dc16dc6075d5ca41c412b945f4264f3398997beb3c052c787fa50342494721d608cf2d367013cb4e7879b7f05bfca9a7999050019 libkcddb-21.12.1.tar.xz
+63846960a2817fb4f296818f3d16139bca4f2fc9f38d16417cd395497f6d0b6444acb867108077bf5713fa007c92e9f28d267d23794b490896ec23d6f32f4a79 libkcddb-24.02.2.tar.xz
"