aboutsummaryrefslogtreecommitdiffstats
path: root/community/libkcompactdisc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libkcompactdisc/APKBUILD')
-rw-r--r--community/libkcompactdisc/APKBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/community/libkcompactdisc/APKBUILD b/community/libkcompactdisc/APKBUILD
index 6022015c3a0..7983284775c 100644
--- a/community/libkcompactdisc/APKBUILD
+++ b/community/libkcompactdisc/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=libkcompactdisc
-pkgver=22.04.2
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> solid
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://www.kde.org/applications/multimedia/"
pkgdesc="Library for interfacing with CDs"
license="GPL-2.0-or-later AND LGPL-2.0-or-later"
@@ -14,16 +16,17 @@ makedepends="
kcoreaddons-dev
ki18n-dev
phonon-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
samurai
solid-dev
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/libkcompactdisc-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/multimedia/libkcompactdisc.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/libkcompactdisc-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
+ -DBUILD_WITH_QT6=ON \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -31,8 +34,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -40,5 +42,5 @@ package() {
}
sha512sums="
-997efdddab3ef98bbd4ed7a94f0acd9176194c4f50a9739ee2a5b869c487d8231194d863e9768f42b8f5d1d9f7863f49c552dbb07d3649ee7be92fa28b88bb4e libkcompactdisc-22.04.2.tar.xz
+46e82a9e565f6694445d271689066cd582bec977078c47e23784b262b6cb66c603e948b2ab3778c3c7ff6886fecdb7d09dc608e299e281b39c8515c040cc06e6 libkcompactdisc-24.02.2.tar.xz
"