aboutsummaryrefslogtreecommitdiffstats
path: root/community/libkdcraw/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libkdcraw/APKBUILD')
-rw-r--r--community/libkdcraw/APKBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/community/libkdcraw/APKBUILD b/community/libkdcraw/APKBUILD
index 93184254f15..50224519d54 100644
--- a/community/libkdcraw/APKBUILD
+++ b/community/libkdcraw/APKBUILD
@@ -1,24 +1,27 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=libkdcraw
-pkgver=22.04.2
+pkgver=24.02.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x blocked by qt5-qtbase-x11
-arch="all !armhf !s390x"
+arch="all !armhf"
url="https://kde.org"
pkgdesc="RAW image file format support for KDE"
license="GPL-2.0-or-later AND LGPL-2.0-or-later"
depends_dev="
libraw-dev
- qt5-qtbase-dev
- samurai
+ qt6-qtbase-dev
"
makedepends="$depends_dev
extra-cmake-modules
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/libkdcraw-$pkgver.tar.xz"
subpackages="$pkgname-dev"
+_repo_url="https://invent.kde.org/graphics/libkdcraw.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/libkdcraw-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -29,14 +32,13 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-41332675859605548b89aee573ba06b1b4692ee3c851b24eef5dd23c44dbf403243cc46163b4dd0596c6a05e1bcaa154c433a14124d0da390613e98b60eb126a libkdcraw-22.04.2.tar.xz
+610c14a324f38d196374b109dc48d8ebac8c6f9a7a80bbb80f01bde1908a3b29edf8d08247c06f61253b61e090e568c6801c85cb1c54690dc0a71e294119ace6 libkdcraw-24.02.1.tar.xz
"