aboutsummaryrefslogtreecommitdiffstats
path: root/community/libkdcraw/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libkdcraw/APKBUILD')
-rw-r--r--community/libkdcraw/APKBUILD27
1 files changed, 15 insertions, 12 deletions
diff --git a/community/libkdcraw/APKBUILD b/community/libkdcraw/APKBUILD
index b3999393128..5befec9ade5 100644
--- a/community/libkdcraw/APKBUILD
+++ b/community/libkdcraw/APKBUILD
@@ -1,41 +1,44 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=libkdcraw
-pkgver=21.08.3
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x blocked by qt5-qtbase-x11
-arch="all !armhf !s390x"
+arch="all !armhf"
url="https://kde.org"
pkgdesc="RAW image file format support for KDE"
license="GPL-2.0-or-later AND LGPL-2.0-or-later"
depends_dev="
libraw-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
"
makedepends="$depends_dev
extra-cmake-modules
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/libkdcraw-$pkgver.tar.xz"
subpackages="$pkgname-dev"
+_repo_url="https://invent.kde.org/graphics/libkdcraw.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/libkdcraw-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-207d3be458f1137fb617d916676a4bdb9241e323f4135231636a717e8d5e80b55b66b7de0d5048f3e8235fe22d22c29f59d1dd804f5bfa709a22f2217c541a6f libkdcraw-21.08.3.tar.xz
+6d91c4d20b3055c1bf870b75135990744bd87cd2f150ad562d6b0c06f2231b9be8f6d471bdfdc3932a834bcc9c3e1023a6573d66098c512f5bb96237411cee64 libkdcraw-24.02.2.tar.xz
"