aboutsummaryrefslogtreecommitdiffstats
path: root/community/libkeduvocdocument/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libkeduvocdocument/APKBUILD')
-rw-r--r--community/libkeduvocdocument/APKBUILD24
1 files changed, 14 insertions, 10 deletions
diff --git a/community/libkeduvocdocument/APKBUILD b/community/libkeduvocdocument/APKBUILD
index 8d153aeac62..eeae238a643 100644
--- a/community/libkeduvocdocument/APKBUILD
+++ b/community/libkeduvocdocument/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=libkeduvocdocument
-pkgver=21.12.1
+pkgver=24.02.1
pkgrel=0
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://edu.kde.org"
pkgdesc="Library to parse, convert, and manipulate KVTML files"
license="GPL-2.0-or-later AND GFDL-1.2-only"
@@ -13,22 +15,24 @@ makedepends="
karchive-dev
ki18n-dev
kio-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
"
+_repo_url="https://invent.kde.org/education/libkeduvocdocument.git"
source="https://download.kde.org/stable/release-service/$pkgver/src/libkeduvocdocument-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-lang"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DBUILD_WITH_QT6=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -36,5 +40,5 @@ package() {
}
sha512sums="
-d86c45e25f9df939ed93d2032cdc7417fe70d1849abe8288ef15621a999449aa5dd0ed6bb66b115fc9983752304bfecaa6a1ff8e43ea61ce40e94b1508a102a9 libkeduvocdocument-21.12.1.tar.xz
+977d064135f3deeff6e5acf4b0e27d0ee84d900e8bb817bd4bad168930564a7c53a577b0efb09b2dd5f7af64c6f19616ade5c8ab1c850672ee9538bf0b842de4 libkeduvocdocument-24.02.1.tar.xz
"