aboutsummaryrefslogtreecommitdiffstats
path: root/community/libkeduvocdocument/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libkeduvocdocument/APKBUILD')
-rw-r--r--community/libkeduvocdocument/APKBUILD24
1 files changed, 14 insertions, 10 deletions
diff --git a/community/libkeduvocdocument/APKBUILD b/community/libkeduvocdocument/APKBUILD
index 554c1025dc1..73c404f5c53 100644
--- a/community/libkeduvocdocument/APKBUILD
+++ b/community/libkeduvocdocument/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=libkeduvocdocument
-pkgver=21.08.3
+pkgver=24.02.2
pkgrel=0
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://edu.kde.org"
pkgdesc="Library to parse, convert, and manipulate KVTML files"
license="GPL-2.0-or-later AND GFDL-1.2-only"
@@ -13,22 +15,24 @@ makedepends="
karchive-dev
ki18n-dev
kio-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
"
+_repo_url="https://invent.kde.org/education/libkeduvocdocument.git"
source="https://download.kde.org/stable/release-service/$pkgver/src/libkeduvocdocument-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-lang"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DBUILD_WITH_QT6=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -36,5 +40,5 @@ package() {
}
sha512sums="
-4a2d1ed17801c8dadbf45111b8f6ab4ccdc0edf1e9395e9f2d5ff0463fde40b4d65b81e701fbf1966755e2b285f99e2b3b24964857dcba553c7081e88c065fc9 libkeduvocdocument-21.08.3.tar.xz
+b0851f80c9e1c1bd857a40811416c1823a7b6f68794ff4775ff9194082e7e569d79ccd30b38595672c80a9dcc9d29c9bc9358febe7d49e434d5e049323a6e4a3 libkeduvocdocument-24.02.2.tar.xz
"